CVE-2024-43430
CVE-2024-43430 · Moodle: lack of access control when using external methods for quiz overrides
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A flaw was found in moodle. External API access to Quiz can override contained insufficient access control.
CVSS 5.3 · Medium · EPSS 0.3% · Fix available
- Published
- Updated
Affected products and versions
moodle/moodle Packagist
- Versions
- v4.4.0
- v4.4.1
- Affected ranges
- ECOSYSTEM: ≥ 4.4.0, < 4.4.2
Update to 4.4.2
moodle Ubuntu:Pro:16.04:LTS
- Versions
- 2.7.9+dfsg-1
- 2.7.10+dfsg-1
- 2.7.11+dfsg-1
- 2.7.11+dfsg-2
- 2.7.12+dfsg-1
- 3.0.3+dfsg-0ubuntu1
- 3.0.3+dfsg-0ubuntu1+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
moodle Ubuntu:Pro:18.04:LTS
- Versions
- 3.0.3+dfsg-0ubuntu1
- 3.0.3+dfsg-0ubuntu1+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published