p PatchFirst

CVE-2024-43497

CVE-2024-43497 · DeepSpeed Remote Code Execution Vulnerability

This page contains facts from public vulnerability sources. Check the original advisory before updating.

DeepSpeed Remote Code Execution Vulnerability

CVSS 8.4 · High · EPSS 0.7% · Fix available

Published
Updated

Stack: python

Affected products and versions

  • deepspeed

    Versions
    • ≥ 0.1.1, < 0.15.1: Affected (custom)

    Update to 0.15.1

  • deepspeed PyPI

    Versions
    • 0.10.0
    • 0.10.1
    • 0.10.2
    • 0.10.3
    • 0.11.0
    • 0.11.1
    • 0.11.2
    • 0.12.0
    • 0.12.1
    • 0.12.2
    • 0.12.3
    • 0.12.4
    • 0.12.5
    • 0.12.6
    • 0.13.0
    • 0.13.1
    • 0.13.2
    • 0.13.3
    • 0.13.4
    • 0.13.5
    • 0.14.0
    • 0.14.1
    • 0.14.2
    • 0.14.3
    • 0.14.4
    • 0.14.5
    • 0.15.0
    • 0.3.1
    • 0.3.1.dev1
    • 0.3.1.dev2
    • 0.3.1.dev3
    • 0.3.1.dev4
    • 0.3.1.dev5
    • 0.3.1.dev6
    • 0.3.1.dev7
    • 0.3.1.dev8
    • 0.3.10
    • 0.3.11
    • 0.3.12
    • 0.3.13
    • 0.3.14
    • 0.3.15
    • 0.3.16
    • 0.3.2
    • 0.3.3
    • 0.3.4
    • 0.3.5
    • 0.3.6
    • 0.3.7
    • 0.3.8
    • 0.3.9
    • 0.4.0
    • 0.4.1
    • 0.4.2
    • 0.4.3
    • 0.4.4
    • 0.4.5
    • 0.5.0
    • 0.5.1
    • 0.5.10
    • 0.5.2
    • 0.5.3
    • 0.5.4
    • 0.5.5
    • 0.5.6
    • 0.5.7
    • 0.5.8
    • 0.5.9
    • 0.6.0
    • 0.6.1
    • 0.6.3
    • 0.6.4
    • 0.6.5
    • 0.6.6
    • 0.6.7
    • 0.7.0
    • 0.7.1
    • 0.7.2
    • 0.7.3
    • 0.7.4
    • 0.7.5
    • 0.7.6
    • 0.7.7
    • 0.8.0
    • 0.8.1
    • 0.8.2
    • 0.8.3
    • 0.9.0
    • 0.9.1
    • 0.9.2
    • 0.9.3
    • 0.9.4
    • 0.9.5
    Affected ranges
    • ECOSYSTEM: < 0.15.1

    Update to 0.15.1

Original sources

Check your server →