CVE-2024-43598
CVE-2024-43598 · LightGBM Remote Code Execution Vulnerability
This page contains facts from public vulnerability sources. Check the original advisory before updating.
LightGBM Remote Code Execution Vulnerability
CVSS 8.1 · High · EPSS 1.4% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
lightgbm
- Versions
- ≥ 1.0.0, < 4.6.0: Affected (custom)
Update to 4.6.0
lightgbm PyPI
- Versions
- 2.0.10
- 2.0.11
- 2.0.12
- 2.0.2
- 2.0.3
- 2.0.4
- 2.0.5
- 2.0.6
- 2.0.7
- 2.1.0
- 2.1.1
- 2.1.2
- 2.2.0
- 2.2.1
- 2.2.2
- 2.2.3
- 2.3.0
- 2.3.1
- 3.0.0
- 3.0.0rc1
- 3.1.0
- 3.1.1
- 3.2.0
- 3.2.1
- 3.3.0
- 3.3.1
- 3.3.2
- 3.3.3
- 3.3.4
- 3.3.5
- 4.0.0
- 4.1.0
- 4.2.0
- 4.3.0
- 4.4.0
- 4.5.0
- Affected ranges
- ECOSYSTEM: ≥ 1.0.0, < 4.6.0
Update to 4.6.0
lightgbm PyPI
- Versions
- 2.0.10
- 2.0.11
- 2.0.12
- 2.0.2
- 2.0.3
- 2.0.4
- 2.0.5
- 2.0.6
- 2.0.7
- 2.1.0
- 2.1.1
- 2.1.2
- 2.2.0
- 2.2.1
- 2.2.2
- 2.2.3
- 2.3.0
- 2.3.1
- 3.0.0
- 3.0.0rc1
- 3.1.0
- 3.1.1
- 3.2.0
- 3.2.1
- 3.3.0
- 3.3.1
- 3.3.2
- 3.3.3
- 3.3.4
- 3.3.5
- 4.0.0
- 4.1.0
- 4.2.0
- 4.3.0
- 4.4.0
- 4.5.0
- Affected ranges
- ECOSYSTEM: < 4.6.0
Update to 4.6.0