p PatchFirst

CVE-2024-4439

CVE-2024-4439

This page contains facts from public vulnerability sources. Check the original advisory before updating.

WordPress Core is vulnerable to Stored Cross-Site Scripting via user display names in the Avatar block in various versions up to 6.5.2 due to insufficient output escaping on the display name. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. In addition, it also makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that have the comment block present and display the comment author's avatar.

CVSS 7.2 · High · EPSS 71.0% · Public exploit · Fix available

Published
Updated

Stack: system

Affected products and versions

  • wordpress

    Versions
    • ≥ 6.0, ≤ 6.0.7: Affected (semver)
    • ≥ 6.1, ≤ 6.1.5: Affected (semver)
    • ≥ 6.2, ≤ 6.2.4: Affected (semver)
    • ≥ 6.3, ≤ 6.3.3: Affected (semver)
    • ≥ 6.4, ≤ 6.4.3: Affected (semver)
    • ≥ 6.5, ≤ 6.5.1: Affected (semver)

    No fix published

  • wordpress Debian:12

    Versions
    • 6.1.1+dfsg1-1
    • 6.1.6+dfsg1-0+deb12u1
    Affected ranges
    • ECOSYSTEM: < 6.1.9+dfsg1-0+deb12u1

    Update to 6.1.9+dfsg1-0+deb12u1

  • wordpress Debian:13

    Affected ranges
    • ECOSYSTEM: < 6.5.2+dfsg1-1

    Update to 6.5.2+dfsg1-1

  • wordpress Debian:14

    Affected ranges
    • ECOSYSTEM: < 6.5.2+dfsg1-1

    Update to 6.5.2+dfsg1-1

  • wordpress Ubuntu:16.04:LTS

    Versions
    • 4.3+dfsg-1
    • 4.3.1+dfsg-1
    • 4.4+dfsg-1
    • 4.4.1+dfsg-1
    • 4.4.2+dfsg-1
    • 4.4.2+dfsg-1ubuntu1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • wordpress Ubuntu:18.04:LTS

    Versions
    • 4.8.2+dfsg-2
    • 4.8.3+dfsg-1
    • 4.9.1+dfsg-1
    • 4.9.2+dfsg-1
    • 4.9.4+dfsg-1
    • 4.9.5+dfsg1-1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • wordpress Ubuntu:20.04:LTS

    Versions
    • 5.2.2+dfsg1-1
    • 5.2.4+dfsg1-1
    • 5.3.2+dfsg1-1
    • 5.3.2+dfsg1-1ubuntu1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • wordpress Ubuntu:22.04:LTS

    Versions
    • 5.7.1+dfsg1-2ubuntu1
    • 5.8.1+dfsg1-2ubuntu1
    • 5.8.2+dfsg1-1ubuntu1
    • 5.8.3+dfsg1-1ubuntu1
    • 5.8.3+dfsg1-1ubuntu1.1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • wordpress Ubuntu:24.04:LTS

    Versions
    • 6.2+dfsg1-1ubuntu1
    • 6.4.3+dfsg1-1ubuntu1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →