p PatchFirst

CVE-2024-4442

CVE-2024-4442 · Salon booking system <= 9.9 - Unauthenticated Arbitrary File Deletion

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The Salon booking system plugin for WordPress is vulnerable to arbitrary file deletion in all versions up to, and including, 9.8. This is due to the plugin not properly validating the path of an uploaded file prior to deleting it. This makes it possible for unauthenticated attackers to delete arbitrary files, including the wp-config.php file, which can make site takeover and remote code execution possible. This was partially patched in 9.9, and sufficiently patched in 10.0. CVE-2024-37231 appears to be a duplicate of this issue.

CVSS 9.1 · Critical · EPSS 1.2% · Public exploit

Published
Updated

Affected products and versions

Original sources

Check your server →