p PatchFirst

CVE-2024-45033

CVE-2024-45033 · Apache Airflow Fab Provider: Application does not invalidate session after password change via Airflow cli

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Insufficient Session Expiration vulnerability in Apache Airflow Fab Provider. This issue affects Apache Airflow Fab Provider: before 1.5.2. When user password has been changed with admin CLI, the sessions for that user have not been cleared, leading to insufficient session expiration, thus logged users could continue to be logged in even after the password was changed. This only happened when the password was changed with CLI. The problem does not happen in case change was done with webserver thus this is different from  CVE-2023-40273 https://github.com/advisories/GHSA-pm87-24wq-r8w9  which was addressed in Apache-Airflow 2.7.0 Users are recommended to upgrade to version 1.5.2, which fixes the issue.

CVSS 8.1 · High · EPSS 1.0% · Fix available

Published
Updated

Stack: python

Affected products and versions

  • apache airflow fab provider

    Versions
    • ≥ 0, < 1.5.2: Affected (semver)

    Update to 1.5.2

  • apache-airflow-providers-fab PyPI

    Versions
    • 1.0.0
    • 1.0.0rc1
    • 1.0.1
    • 1.0.1.dev0
    • 1.0.2
    • 1.0.2.dev0
    • 1.0.2.dev1
    • 1.0.2.dev2
    • 1.0.2b0
    • 1.0.2rc1
    • 1.0.3
    • 1.0.3rc1
    • 1.0.4
    • 1.0.4rc1
    • 1.1.0
    • 1.1.0rc1
    • 1.1.1
    • 1.1.1rc1
    • 1.2.0
    • 1.2.0rc1
    • 1.2.1
    • 1.2.1rc1
    • 1.2.2
    • 1.2.2rc1
    • 1.3.0
    • 1.3.0rc1
    • 1.4.0
    • 1.4.0rc1
    • 1.4.1
    • 1.4.1rc1
    • 1.5.0
    • 1.5.0rc1
    • 1.5.0rc2
    • 1.5.0rc3
    • 1.5.1
    • 1.5.1rc1
    • 1.5.2rc1
    Affected ranges
    • ECOSYSTEM: < 1.5.2

    Update to 1.5.2

Original sources

Check your server →