CVE-2024-45498
CVE-2024-45498 · Apache Airflow: Command Injection in an example DAG
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Example DAG: example_inlet_event_extra.py shipped with Apache Airflow version 2.10.0 has a vulnerability that allows an authenticated attacker with only DAG trigger permission to execute arbitrary commands. If you used that example as the base of your DAGs - please review if you have not copied the dangerous example; see https://github.com/apache/airflow/pull/41873 for more information. We recommend against exposing the example DAGs in your deployment. If you must expose the example DAGs, upgrade Airflow to version 2.10.1 or later.
CVSS 8.8 · High · EPSS 1.2% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
apache airflow
- Versions
- 2.10.0: Affected (semver)
No fix published
apache-airflow PyPI
- Versions
- 2.10.0
- 2.10.1rc1
- Affected ranges
- ECOSYSTEM: ≥ 2.10.0, < 2.10.1
Update to 2.10.1
apache-airflow PyPI
- Affected ranges
- ECOSYSTEM: ≤ 2.10.0-NA
No fix published