CVE-2024-45595
CVE-2024-45595 · D-Tale allows Remote Code Execution through the Query input on Chart Builder
This page contains facts from public vulnerability sources. Check the original advisory before updating.
D-Tale is a visualizer for Pandas data structures. Users hosting D-Tale publicly can be vulnerable to remote code execution allowing attackers to run malicious code on the server. Users should upgrade to version 3.14.1 where the "Custom Filter" input is turned off by default.
CVSS 6.1 · Medium · EPSS 0.8% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
dtale
- Versions
- < 3.14.1: Affected
No fix published
dtale PyPI
- Versions
- 1.0.0
- 1.1.1
- 1.10.0
- 1.11.0
- 1.12.1
- 1.13.0
- 1.14.1
- 1.15.2
- 1.16.0
- 1.17.0
- 1.18.2
- 1.19.2
- 1.2.0
- 1.20.0
- 1.21.1
- 1.22.0
- 1.22.1
- 1.23.0
- 1.24.0
- 1.25.0
- 1.26.0
- 1.27.0
- 1.28.0
- 1.28.1
- 1.29.0
- 1.29.1
- 1.3.7
- 1.30.0
- 1.31.0
- 1.32.0
- 1.32.1
- 1.33.0
- 1.33.1
- 1.34.0
- 1.35.0
- 1.36.0
- 1.37.0
- 1.37.1
- 1.38.0
- 1.39.0
- 1.4.1
- 1.40.0
- 1.40.1
- 1.40.2
- 1.41.0
- 1.41.1
- 1.42.0
- 1.42.1
- 1.43.0
- 1.44.0
- 1.44.1
- 1.45.0
- 1.46.0
- 1.47.0
- 1.48.0
- 1.49.0
- 1.5.1
- 1.50.0
- 1.50.1
- 1.51.0
- 1.52.0
- 1.53.0
- 1.54.0
- 1.54.1
- 1.55.0
- 1.56.0
- 1.57.0
- 1.58.1
- 1.58.2
- 1.58.3
- 1.59.0
- 1.59.1
- 1.6.10
- 1.6.5
- 1.6.6
- 1.6.7
- 1.6.8
- 1.6.9
- 1.60.1
- 1.60.2
- 1.61.0
- 1.61.1
- 1.7.0
- 1.7.1
- 1.7.10
- 1.7.11
- 1.7.12
- 1.7.13
- 1.7.14
- 1.7.15
- 1.7.2
- 1.7.3
- 1.7.4
- 1.7.5
- 1.7.6
- 1.7.7
- 1.7.8
- 1.7.9
- 1.8.0
- 1.8.1
- 1.8.10
- 1.8.11
- 1.8.12
- 1.8.13
- 1.8.14
- 1.8.15
- 1.8.16
- 1.8.17
- 1.8.18
- 1.8.19
- 1.8.3
- 1.8.4
- 1.8.6
- 1.8.7
- 1.8.8
- 1.8.9
- 1.9.0
- 1.9.1
- 1.9.2
- 2.0.0
- 2.1.0
- 2.1.2
- 2.10.0
- 2.11.0
- 2.12.0
- 2.12.1
- 2.12.2
- 2.12.3
- 2.13.0
- 2.14.0
- 2.14.1
- 2.15.0
- 2.15.2
- 2.16.0
- 2.2.0
- 2.3.0
- 2.4.0
- 2.5.1
- 2.6.0
- 2.7.1
- 2.8.0
- 2.8.1
- 2.9.0
- 2.9.1
- 3.0.0
- 3.1.0
- 3.1.6
- 3.1.7
- 3.10.0
- 3.11.0
- 3.12.0
- 3.13.0
- 3.13.1
- 3.14.0
- 3.2.0
- 3.3.0
- 3.4.0
- 3.5.0
- 3.6.0
- 3.7.0
- 3.8.0
- 3.8.1
- 3.9.0
- Affected ranges
- ECOSYSTEM: < 3.14.1
Update to 3.14.1