CVE-2024-45847
CVE-2024-45847
This page contains facts from public vulnerability sources. Check the original advisory before updating.
An arbitrary code execution vulnerability exists in versions 23.11.4.2 up to 24.7.4.1 of the MindsDB platform, when one of several integrations is installed on the server. If a specially crafted ‘UPDATE’ query containing Python code is run against a database created with the specified integration engine, the code will be passed to an eval function and executed on the server.
CVSS 8.8 · High · EPSS 0.9% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
mindsdb
- Versions
- ≥ 23.11.4.2, < 24.7.4.1: Affected (semver)
Update to 24.7.4.1
mindsdb PyPI
- Versions
- 23.11.4.4a6
- 23.12.4.0
- 23.12.4.1
- 23.12.4.2
- 24.1.4.0
- 24.2.3.0
- 24.3.4.0
- 24.3.4.1
- 24.3.4.2
- 24.3.5.0
- 24.4.2.0
- 24.4.2.1
- 24.4.3.0
- 24.5.4.0
- 24.6.1.0
- 24.6.1.1
- 24.6.2.0
- 24.6.2.2
- 24.6.3.0
- 24.6.3.1
- 24.6.4.1
- 24.7.1.0
- 24.7.2.0
- 24.7.3.0
- 24.7.4.0
- Affected ranges
- ECOSYSTEM: ≥ 23.11.4.2, < 24.7.4.1
Update to 24.7.4.1