CVE-2024-47068
CVE-2024-47068 · DOM Clobbering Gadget found in rollup bundled scripts that leads to XSS
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Rollup is a module bundler for JavaScript. Versions prior to 2.79.2, 3.29.5, and 4.22.4 are susceptible to a DOM Clobbering vulnerability when bundling scripts with properties from `import.meta` (e.g., `import.meta.url`) in `cjs`/`umd`/`iife` format. The DOM Clobbering gadget can lead to cross-site scripting (XSS) in web pages where scriptless attacker-controlled HTML elements (e.g., an `img` tag with an unsanitized `name` attribute) are present. Versions 2.79.2, 3.29.5, and 4.22.4 contain a patch for the vulnerability.
CVSS 6.1 · Medium · EPSS 0.7% · Fix available
- Published
- Updated
Affected products and versions
rollup
- Versions
- >= 3.0.0, < 3.29.5: Affected
- >= 4.0.0, < 4.22.4: Affected
- < 2.79.2: Affected
No fix published
node-rollup Debian:12
- Versions
- 3.15.0-1
- 3.15.0-1+deb12u1
- 3.15.0-2
- 3.28.0-1
- 3.28.0-2
- 3.29.4-1
- 3.29.4-2
- 3.29.4-3
- 3.29.5-1
- 3.29.5-2
- 3.29.5-3
- 3.30.0-1
- 3.30.0-2
- 3.30.0-3
- 3.30.0-4
- 3.30.0-5
- 3.30.0-6
- 3.30.0-7
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-rollup Debian:13
- Affected ranges
- ECOSYSTEM: < 3.29.5-1
Update to 3.29.5-1
node-rollup Debian:14
- Affected ranges
- ECOSYSTEM: < 3.29.5-1
Update to 3.29.5-1
rollup npm
- Affected ranges
- SEMVER: ≥ 3.0.0, < 3.29.5
Update to 3.29.5
rollup npm
- Affected ranges
- SEMVER: ≥ 4.0.0, < 4.22.4
Update to 4.22.4
rollup npm
- Affected ranges
- SEMVER: < 2.79.2
Update to 2.79.2
node-rollup Ubuntu:20.04:LTS
- Versions
- 0.50.0-6build3
- 0.68.2-2
- 1.12.0-2build2
- 1.12.0-2build3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-rollup Ubuntu:22.04:LTS
- Versions
- 2.38.4-1
- 2.42.1-2
- 2.61.1-5
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-rollup Ubuntu:24.04:LTS
- Versions
- 3.28.0-2
- 3.29.4-2
- 3.29.4-3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-rollup Ubuntu:25.10
- Versions
- 3.29.5-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-rollup Ubuntu:26.10
- Versions
- 3.30.0-1
- 3.30.0-5build5
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-rollup Ubuntu:26.04:LTS
- Versions
- 3.29.5-1
- 3.30.0-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://github.com/rollup/rollup/security/advisories/GHSA-gcx4-mw62-g8wm
- https://github.com/rollup/rollup/commit/2ef77c00ec2635d42697cff2c0567ccc8db34fb4
- https://github.com/rollup/rollup/commit/e2552c9e955e0a61f70f508200ee9f752f85a541
- https://github.com/rollup/rollup/blob/b86ffd776cfa906573d36c3f019316d02445d9ef/src/ast/nodes/MetaProperty.ts#L157-L162
- https://github.com/rollup/rollup/blob/b86ffd776cfa906573d36c3f019316d02445d9ef/src/ast/nodes/MetaProperty.ts#L180-L185
- https://nvd.nist.gov/vuln/detail/CVE-2024-47068