CVE-2024-47545
CVE-2024-47545 · GHSL-2024-242: GStreamer has an integer underflow in FOURCC_strf parsing leading to OOB-read
This page contains facts from public vulnerability sources. Check the original advisory before updating.
GStreamer is a library for constructing graphs of media-handling components. An integer underflow has been detected in qtdemux_parse_trak function within qtdemux.c. During the strf parsing case, the subtraction size -= 40 can lead to a negative integer overflow if it is less than 40. If this happens, the subsequent call to gst_buffer_fill will invoke memcpy with a large tocopy size, resulting in an OOB-read. This vulnerability is fixed in 1.24.10.
CVSS 6.9 · Medium · EPSS 1.1% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
gstreamer
- Versions
- < 1.24.10: Affected
No fix published
gst-plugins-good1.0 Debian:12
- Versions
- 1.22.0-5
- 1.22.0-5+deb12u1
- Affected ranges
- ECOSYSTEM: < 1.22.0-5+deb12u2
Update to 1.22.0-5+deb12u2
gst-plugins-good1.0 Debian:13
- Affected ranges
- ECOSYSTEM: < 1.24.10-1
Update to 1.24.10-1
gst-plugins-good1.0 Debian:14
- Affected ranges
- ECOSYSTEM: < 1.24.10-1
Update to 1.24.10-1
gst-plugins-good1.0 Ubuntu:Pro:16.04:LTS
- Versions
- 1.6.0-1ubuntu1
- 1.6.1-1ubuntu1
- 1.6.2-1ubuntu1
- 1.7.1-1ubuntu1
- 1.7.2-1ubuntu1
- 1.7.90-1ubuntu1
- 1.7.91-1ubuntu1
- 1.8.0-1ubuntu1
- 1.8.1-1ubuntu0.1
- 1.8.2-1ubuntu0.1
- 1.8.2-1ubuntu0.2
- 1.8.2-1ubuntu0.3
- 1.8.3-1ubuntu0.3
- 1.8.3-1ubuntu0.4
- 1.8.3-1ubuntu0.5
- 1.8.3-1ubuntu0.5+esm1
- 1.8.3-1ubuntu0.5+esm2
- 1.8.3-1ubuntu0.5+esm3
- 1.8.3-1ubuntu0.5+esm4
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
gst-plugins-good0.10 Ubuntu:16.04:LTS
- Versions
- 0.10.31-3+nmu4ubuntu2~gcc5.1
- 0.10.31-3+nmu4ubuntu2.16.04.1
- 0.10.31-3+nmu4ubuntu2.16.04.2
- 0.10.31-3+nmu4ubuntu2.16.04.3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
gst-plugins-good1.0 Ubuntu:Pro:18.04:LTS
- Versions
- 1.12.3-1ubuntu1
- 1.12.4-1ubuntu1
- 1.13.1-1ubuntu1
- 1.13.91-1ubuntu1
- 1.14.0-1ubuntu1
- 1.14.1-1ubuntu1~ubuntu18.04.1
- 1.14.4-1ubuntu1~ubuntu18.04.1
- 1.14.5-0ubuntu1~18.04.1
- 1.14.5-0ubuntu1~18.04.2
- 1.14.5-0ubuntu1~18.04.3
- 1.14.5-0ubuntu1~18.04.3+esm1
- 1.14.5-0ubuntu1~18.04.3+esm2
- 1.14.5-0ubuntu1~18.04.3+esm3
- 1.14.5-0ubuntu1~18.04.3+esm4
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
gst-plugins-good1.0 Ubuntu:20.04:LTS
- Versions
- 1.16.1-1ubuntu1
- 1.16.2-1ubuntu1
- 1.16.2-1ubuntu2
- 1.16.2-1ubuntu2.1
- 1.16.3-0ubuntu1
- 1.16.3-0ubuntu1.1
- 1.16.3-0ubuntu1.2
- Affected ranges
- ECOSYSTEM: < 1.16.3-0ubuntu1.3
Update to 1.16.3-0ubuntu1.3
gst-plugins-good1.0 Ubuntu:22.04:LTS
- Versions
- 1.18.5-1ubuntu2
- 1.18.5-1ubuntu3
- 1.20.0-2ubuntu1
- 1.20.1-1ubuntu1
- 1.20.3-0ubuntu1
- 1.20.3-0ubuntu1.1
- Affected ranges
- ECOSYSTEM: < 1.20.3-0ubuntu1.3
Update to 1.20.3-0ubuntu1.3
gst-plugins-good1.0 Ubuntu:24.04:LTS
- Versions
- 1.22.6-1ubuntu1
- 1.22.6-1ubuntu2
- 1.22.8-3ubuntu1
- 1.22.9-1ubuntu1
- 1.24.0-1ubuntu5
- 1.24.0-1ubuntu7
- 1.24.1-2ubuntu1
- 1.24.2-1ubuntu1
- Affected ranges
- ECOSYSTEM: < 1.24.2-1ubuntu1.1
Update to 1.24.2-1ubuntu1.1
Original sources
- https://securitylab.github.com/advisories/GHSL-2024-242_Gstreamer/
- https://gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/8059.patch
- https://gstreamer.freedesktop.org/security/sa-2024-0010.html
- https://lists.debian.org/debian-lts-announce/2025/02/msg00035.html
- https://nvd.nist.gov/vuln/detail/CVE-2024-47545