CVE-2024-47887
CVE-2024-47887 · Action Controller has possible ReDoS vulnerability in HTTP Token authentication
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Action Pack is a framework for handling and responding to web requests. Starting in version 4.0.0 and prior to versions 6.1.7.9, 7.0.8.5, 7.1.4.1, and 7.2.1.1, there is a possible ReDoS vulnerability in Action Controller's HTTP Token authentication. For applications using HTTP Token authentication via `authenticate_or_request_with_http_token` or similar, a carefully crafted header may cause header parsing to take an unexpected amount of time, possibly resulting in a DoS vulnerability. All users running an affected release should either upgrade to versions 6.1.7.9, 7.0.8.5, 7.1.4.1, or 7.2.1.1 or apply the relevant patch immediately. One may choose to use Ruby 3.2 as a workaround.Ruby 3.2 has mitigations for this problem, so Rails applications using Ruby 3.2 or newer are unaffected. Rails 8.0.0.beta1 depends on Ruby 3.2 or greater so is unaffected.
CVSS 6.6 · Medium · EPSS 1.0% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
rails
- Versions
- >= 4.0.0, < 6.1.7.9: Affected
- >= 7.0.0, < 7.0.8.5: Affected
- >= 7.1.0, < 7.1.4.1: Affected
- >= 7.2.0, < 7.2.1.1: Affected
No fix published
rails Debian:12
- Versions
- 2:6.1.7.3+dfsg-1
- 2:6.1.7.3+dfsg-10
- 2:6.1.7.3+dfsg-11
- 2:6.1.7.3+dfsg-12
- 2:6.1.7.3+dfsg-13
- 2:6.1.7.3+dfsg-2
- 2:6.1.7.3+dfsg-2~deb12u1
- 2:6.1.7.3+dfsg-3
- 2:6.1.7.3+dfsg-4
- 2:6.1.7.3+dfsg-5
- 2:6.1.7.3+dfsg-6
- 2:6.1.7.3+dfsg-7
- 2:6.1.7.3+dfsg-7~exp1
- 2:6.1.7.3+dfsg-8
- 2:6.1.7.3+dfsg-9
- Affected ranges
- ECOSYSTEM: < 2:6.1.7.10+dfsg-1~deb12u1
Update to 2:6.1.7.10+dfsg-1~deb12u1
rails Debian:13
- Affected ranges
- ECOSYSTEM: < 2:7.2.2.1+dfsg-1
Update to 2:7.2.2.1+dfsg-1
rails Debian:14
- Affected ranges
- ECOSYSTEM: < 2:7.2.2.1+dfsg-1
Update to 2:7.2.2.1+dfsg-1
rails Ubuntu:Pro:16.04:LTS
- Versions
- 2:4.1.10-1
- 2:4.2.5-1
- 2:4.2.5.1-1
- 2:4.2.5.2-2
- 2:4.2.6-1
- Affected ranges
- ECOSYSTEM: < 2:4.2.6-1ubuntu0.1~esm1
Update to 2:4.2.6-1ubuntu0.1~esm1
rails Ubuntu:Pro:18.04:LTS
- Versions
- 2:4.2.9-2
- 2:4.2.9-4
- 2:4.2.10-0ubuntu4
- Affected ranges
- ECOSYSTEM: < 2:4.2.10-0ubuntu4+esm1
Update to 2:4.2.10-0ubuntu4+esm1
rails Ubuntu:Pro:20.04:LTS
- Versions
- 2:5.2.2.1+dfsg-1ubuntu1
- 2:5.2.3+dfsg-3
- Affected ranges
- ECOSYSTEM: < 2:5.2.3+dfsg-3ubuntu0.1~esm1
Update to 2:5.2.3+dfsg-3ubuntu0.1~esm1
rails Ubuntu:Pro:22.04:LTS
- Versions
- 2:6.0.3.7+dfsg-2
- 2:6.1.4.1+dfsg-8ubuntu2
- Affected ranges
- ECOSYSTEM: < 2:6.1.4.1+dfsg-8ubuntu2+esm1
Update to 2:6.1.4.1+dfsg-8ubuntu2+esm1
rails Ubuntu:24.04:LTS
- Versions
- 2:6.1.7.3+dfsg-2build1
- 2:6.1.7.3+dfsg-3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
rails Ubuntu:25.10
- Versions
- 2:6.1.7.3+dfsg-7
- 2:7.2.2.1+dfsg-7
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
rails Ubuntu:26.10
- Versions
- 2:7.2.3+dfsg-2
- 2:7.2.3.2+dfsg-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
rails Ubuntu:26.04:LTS
- Versions
- 2:7.2.2.1+dfsg-7
- 2:7.2.2.2+dfsg-2
- 2:7.2.3+dfsg-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://github.com/rails/rails/security/advisories/GHSA-vfg9-r3fq-jvx4
- https://github.com/rails/rails/commit/56b2fc3302836405b496e196a8d5fc0195e55049
- https://github.com/rails/rails/commit/7c1398854d51f9bb193fb79f226647351133d08a
- https://github.com/rails/rails/commit/8e057db25bff1dc7a98e9ae72e0083825b9ac545
- https://github.com/rails/rails/commit/f4dc83d8926509d0958ec21fcdbc2e7df3d32ce2
- https://nvd.nist.gov/vuln/detail/CVE-2024-47887