p PatchFirst

CVE-2024-4835

CVE-2024-4835 · Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A XSS condition exists within GitLab in versions 15.11 before 16.10.6, 16.11 before 16.11.3, and 17.0 before 17.0.1. By leveraging this condition, an attacker can craft a malicious page to exfiltrate sensitive user information.

CVSS 8.0 · High · EPSS 0.8% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • gitlab

    Versions
    • ≥ 15.11, < 16.10.6: Affected (semver)
    • ≥ 16.11, < 16.11.3: Affected (semver)
    • ≥ 17.0, < 17.0.1: Affected (semver)

    Update to 16.10.6; Update to 16.11.3; Update to 17.0.1

  • gitlab Ubuntu:16.04:LTS

    Versions
    • 8.4.3+dfsg-9
    • 8.4.3+dfsg-12
    • 8.5.8+dfsg-5
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →