p PatchFirst

CVE-2024-4901

CVE-2024-4901 · Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab

This page contains facts from public vulnerability sources. Check the original advisory before updating.

An issue was discovered in GitLab CE/EE affecting all versions starting from 16.9 prior to 16.11.5, starting from 17.0 prior to 17.0.3, and starting from 17.1 prior to 17.1.1, where a stored XSS vulnerability could be imported from a project with malicious commit notes.

CVSS 8.7 · High · EPSS 33.0% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • gitlab

    Versions
    • ≥ 16.9, < 16.11.5: Affected (semver)
    • ≥ 17.0, < 17.0.3: Affected (semver)
    • ≥ 17.1, < 17.1.1: Affected (semver)

    Update to 16.11.5; Update to 17.0.3; Update to 17.1.1

  • gitlab Ubuntu:16.04:LTS

    Versions
    • 8.4.3+dfsg-9
    • 8.4.3+dfsg-12
    • 8.5.8+dfsg-5
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →