CVE-2024-49365
CVE-2024-49365 · tiny-secp256k1 allows for verify() bypass when running in bundled environment
This page contains facts from public vulnerability sources. Check the original advisory before updating.
tiny-secp256k1 is a tiny secp256k1 native/JS wrapper. Prior to version 1.1.7, a malicious JSON-stringifyable message can be made passing on verify(), when global Buffer is the buffer package. This affects only environments where require('buffer') is the NPM buffer package. Buffer.isBuffer check can be bypassed, resulting in strange objects being accepted as a message, and those messages could trick verify() into returning false-positive true values. This issue has been patched in version 1.1.7.
CVSS 8.1 · High · EPSS 0.2% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
tiny-secp256k1
- Versions
- < 1.1.7: Affected
No fix published
tiny-secp256k1 npm
- Affected ranges
- SEMVER: < 1.1.7
Update to 1.1.7