CVE-2024-49769
CVE-2024-49769 · Waitress has a denial of service leading to high CPU usage/resource exhaustion
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Waitress is a Web Server Gateway Interface server for Python 2 and 3. When a remote client closes the connection before waitress has had the opportunity to call getpeername() waitress won't correctly clean up the connection leading to the main thread attempting to write to a socket that no longer exists, but not removing it from the list of sockets to attempt to process. This leads to a busy-loop calling the write function. A remote attacker could run waitress out of available sockets with very little resources required. Waitress 3.0.1 contains fixes that remove the race condition.
CVSS 7.5 · High · EPSS 1.4% · Fix available
- Published
- Updated
Affected products and versions
waitress
- Versions
- < 3.0.1: Affected
No fix published
waitress Debian:12
- Versions
- 2.1.2-2
- Affected ranges
- ECOSYSTEM: < 2.1.2-2+deb12u1
Update to 2.1.2-2+deb12u1
waitress Debian:13
- Affected ranges
- ECOSYSTEM: < 3.0.1-1
Update to 3.0.1-1
waitress Debian:14
- Affected ranges
- ECOSYSTEM: < 3.0.1-1
Update to 3.0.1-1
waitress PyPI
- Versions
- 0.1
- 0.2
- 0.3
- 0.4
- 0.5
- 0.6
- 0.6.1
- 0.7
- 0.8
- 0.8.1
- 0.8.10
- 0.8.11b0
- 0.8.2
- 0.8.3
- 0.8.4
- 0.8.5
- 0.8.6
- 0.8.7
- 0.8.8
- 0.8.9
- 0.9.0
- 0.9.0b0
- 0.9.0b1
- 1.0.0
- 1.0.1
- 1.0.2
- 1.0a1
- 1.0a2
- 1.1.0
- 1.2.0
- 1.2.0b1
- 1.2.0b2
- 1.2.0b3
- 1.2.1
- 1.3.0
- 1.3.0b0
- 1.3.1
- 1.4.0
- 1.4.1
- 1.4.2
- 1.4.3
- 1.4.4
- 2.0.0
- 2.0.0b0
- 2.0.0b1
- 2.1.0
- 2.1.0b0
- 2.1.1
- 2.1.2
- 3.0.0
- Affected ranges
- ECOSYSTEM: < 3.0.1
Update to 3.0.1
waitress PyPI
- Versions
- 0.1
- 0.2
- 0.3
- 0.4
- 0.5
- 0.6
- 0.6.1
- 0.7
- 0.8
- 0.8.1
- 0.8.10
- 0.8.11b0
- 0.8.2
- 0.8.3
- 0.8.4
- 0.8.5
- 0.8.6
- 0.8.7
- 0.8.8
- 0.8.9
- 0.9.0
- 0.9.0b0
- 0.9.0b1
- 1.0.0
- 1.0.1
- 1.0.2
- 1.0a1
- 1.0a2
- 1.1.0
- 1.2.0
- 1.2.0b1
- 1.2.0b2
- 1.2.0b3
- 1.2.1
- 1.3.0
- 1.3.0b0
- 1.3.1
- 1.4.0
- 1.4.1
- 1.4.2
- 1.4.3
- 1.4.4
- 2.0.0
- 2.0.0b0
- 2.0.0b1
- 2.1.0
- 2.1.0b0
- 2.1.1
- 2.1.2
- 3.0.0
- Affected ranges
- GIT: < 1ae4e894c9f76543bee06584001583fc6fa8c95c
- ECOSYSTEM: < 3.0.1
Update to 3.0.1
waitress Ubuntu:16.04:LTS
- Versions
- 0.8.9-2ubuntu1
- 0.8.10-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
waitress Ubuntu:18.04:LTS
- Versions
- 1.0.1-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
waitress Ubuntu:20.04:LTS
- Versions
- 1.2.0~b2-2
- 1.3.1-4
- 1.4.1-1
- 1.4.1-1ubuntu0.1
- Affected ranges
- ECOSYSTEM: < 1.4.1-1ubuntu0.2
Update to 1.4.1-1ubuntu0.2
waitress Ubuntu:22.04:LTS
- Versions
- 1.4.4-1.1
- 1.4.4-1.1ubuntu1
- Affected ranges
- ECOSYSTEM: < 1.4.4-1.1ubuntu1.1
Update to 1.4.4-1.1ubuntu1.1
waitress Ubuntu:Pro:24.04:LTS
- Versions
- 2.1.2-2
- Affected ranges
- ECOSYSTEM: < 2.1.2-2ubuntu0.1~esm1
Update to 2.1.2-2ubuntu0.1~esm1
Original sources
- https://github.com/Pylons/waitress/security/advisories/GHSA-3f84-rpwh-47g6
- https://github.com/Pylons/waitress/issues/418
- https://github.com/Pylons/waitress/pull/435
- https://github.com/Pylons/waitress/commit/1ae4e894c9f76543bee06584001583fc6fa8c95c
- https://lists.debian.org/debian-lts-announce/2024/11/msg00012.html
- https://nvd.nist.gov/vuln/detail/CVE-2024-49769