CVE-2024-4990
CVE-2024-4990 · Unsafe Reflection in base Component class in yiisoft/yii2
This page contains facts from public vulnerability sources. Check the original advisory before updating.
In yiisoft/yii2 version 2.0.48, the base Component class contains a vulnerability where the `__set()` magic method does not validate that the value passed is a valid Behavior class name or configuration. This allows an attacker to instantiate arbitrary classes, passing parameters to their constructors and invoking setter methods. Depending on the installed dependencies, various types of attacks are possible, including the execution of arbitrary code, retrieval of sensitive information, and unauthorized access.
CVSS 8.1 · High · EPSS 80.1% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
yiisoft/yii2
- Versions
- ≥ unspecified, ≤ latest: Affected (custom)
No fix published
yiisoft/yii2 Packagist
- Versions
- 2.0.0
- 2.0.0-alpha
- 2.0.0-beta
- 2.0.0-rc
- 2.0.1
- 2.0.10
- 2.0.11
- 2.0.11.1
- 2.0.11.2
- 2.0.12
- 2.0.12.1
- 2.0.12.2
- 2.0.13
- 2.0.13.1
- 2.0.13.2
- 2.0.13.3
- 2.0.14
- 2.0.14.1
- 2.0.14.2
- 2.0.15
- 2.0.15.1
- 2.0.16
- 2.0.16.1
- 2.0.17
- 2.0.18
- 2.0.19
- 2.0.2
- 2.0.20
- 2.0.21
- 2.0.22
- 2.0.23
- 2.0.24
- 2.0.25
- 2.0.26
- 2.0.27
- 2.0.28
- 2.0.29
- 2.0.3
- 2.0.30
- 2.0.31
- 2.0.32
- 2.0.33
- 2.0.34
- 2.0.35
- 2.0.36
- 2.0.37
- 2.0.38
- 2.0.39
- 2.0.39.1
- 2.0.39.2
- 2.0.39.3
- 2.0.4
- 2.0.40
- 2.0.41
- 2.0.41.1
- 2.0.42
- 2.0.42.1
- 2.0.43
- 2.0.44
- 2.0.45
- 2.0.46
- 2.0.47
- 2.0.48
- 2.0.48.1
- 2.0.49
- 2.0.49.1
- 2.0.49.2
- 2.0.49.3
- 2.0.5
- 2.0.6
- 2.0.7
- 2.0.8
- 2.0.9
- Affected ranges
- ECOSYSTEM: < 2.0.49.4
Update to 2.0.49.4