p PatchFirst

CVE-2024-5005

CVE-2024-5005 · Incorrect Provision of Specified Functionality in GitLab

This page contains facts from public vulnerability sources. Check the original advisory before updating.

An issue has been discovered discovered in GitLab EE/CE affecting all versions starting from 11.4 before 17.2.9, all versions starting from 17.3 before 17.3.5, all versions starting from 17.4 before 17.4.2 It was possible for guest users to disclose project templates using the API.

CVSS 4.3 · Medium · EPSS 0.4% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • gitlab

    Versions
    • ≥ 11.4, < 17.2.9: Affected (semver)
    • ≥ 17.3, < 17.3.5: Affected (semver)
    • ≥ 17.4, < 17.4.2: Affected (semver)

    Update to 17.2.9; Update to 17.3.5; Update to 17.4.2

  • gitlab Ubuntu:16.04:LTS

    Versions
    • 8.4.3+dfsg-9
    • 8.4.3+dfsg-12
    • 8.5.8+dfsg-5
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →