p PatchFirst

CVE-2024-5023

CVE-2024-5023 · Arbitrary File Read Vulnerability in ConsoleMe via Limited Git command RCE

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Improper Neutralization of Special Elements used in a Command ('Command Injection') vulnerability in Netflix ConsoleMe allows Command Injection.This issue affects ConsoleMe: before 1.4.0.

CVSS 9.3 · Critical · EPSS 0.9% · Fix available

Published
Updated

Stack: python

Affected products and versions

  • consoleme

    Versions
    • ≥ 0, < 1.4.0: Affected (git)

    Update to 1.4.0

  • consoleme PyPI

    Versions
    • 0.0.0
    • 1.0.6.dev10
    • 1.1.1
    • 1.1.10.dev1
    • 1.1.10.dev2
    • 1.1.10.dev3
    • 1.1.10.dev4
    • 1.1.10.dev5
    • 1.1.10.dev6
    • 1.1.2
    • 1.1.2.dev1
    • 1.1.3
    • 1.1.3.dev1
    • 1.1.3.dev2
    • 1.1.3.dev3
    • 1.1.3.dev4
    • 1.1.3.dev5
    • 1.1.3.dev6
    • 1.1.3.dev7
    • 1.1.3.dev8
    • 1.1.4
    • 1.1.5
    • 1.1.5.dev1
    • 1.1.5.dev2
    • 1.1.5.dev3
    • 1.1.6
    • 1.1.6.dev1
    • 1.1.6.dev2
    • 1.1.7
    • 1.1.8
    • 1.1.8.dev1
    • 1.1.8.dev2
    • 1.1.8.dev3
    • 1.1.8.dev4
    • 1.1.9
    • 1.1.9.dev1
    • 1.2.0
    • 1.2.1
    • 1.2.1.dev1
    • 1.2.2
    • 1.2.2.dev3
    • 1.2.2.dev4
    • 1.2.3.dev1
    • 1.2.3.dev10
    • 1.2.3.dev11
    • 1.2.3.dev12
    • 1.2.3.dev2
    • 1.2.3.dev3
    • 1.2.3.dev4
    • 1.2.3.dev5
    • 1.2.3.dev6
    • 1.2.3.dev7
    • 1.2.3.dev8
    • 1.2.3.dev9
    • 1.3.0
    • 1.3.1
    • 1.3.1.dev3
    • 1.3.2.dev1
    Affected ranges
    • ECOSYSTEM: < 1.4.0

    Update to 1.4.0

Original sources

Check your server →