CVE-2024-5187
CVE-2024-5187 · Arbitrary File Overwrite in download_model_with_test_data in onnx/onnx
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A vulnerability in the `download_model_with_test_data` function of the onnx/onnx framework, version 1.16.0, allows for arbitrary file overwrite due to inadequate prevention of path traversal attacks in malicious tar files. This vulnerability enables attackers to overwrite any file on the system, potentially leading to remote code execution, deletion of system, personal, or application files, thus impacting the integrity and availability of the system. The issue arises from the function's handling of tar file extraction without performing security checks on the paths within the tar file, as demonstrated by the ability to overwrite the `/home/kali/.ssh/authorized_keys` file by specifying an absolute path in the malicious tar file.
CVSS 8.8 · High · EPSS 1.2% · Fix available
- Published
- Updated
Affected products and versions
onnx/onnx
- Versions
- ≥ unspecified, ≤ latest: Affected (custom)
No fix published
onnx Debian:13
- Affected ranges
- ECOSYSTEM: < 1.16.2-1
Update to 1.16.2-1
onnx Debian:14
- Affected ranges
- ECOSYSTEM: < 1.16.2-1
Update to 1.16.2-1
onnx PyPI
- Versions
- 0.1
- 0.2
- 0.2.1
- 1.0.0
- 1.0.1
- 1.1.0
- 1.1.1
- 1.1.2
- 1.10.0
- 1.10.1
- 1.10.2
- 1.11.0
- 1.12.0
- 1.13.0
- 1.13.1
- 1.14.0
- 1.14.1
- 1.15.0
- 1.16.0
- 1.16.1
- 1.2.1
- 1.2.2
- 1.2.3
- 1.3.0
- 1.4.0
- 1.4.1
- 1.5.0
- 1.6.0
- 1.7.0
- 1.8.0
- 1.8.1
- 1.9.0
- Affected ranges
- ECOSYSTEM: < 1.16.2
Update to 1.16.2
onnx PyPI
- Versions
- 0.1
- 0.2
- 0.2.1
- 1.0.0
- 1.0.1
- 1.1.0
- 1.1.1
- 1.1.2
- 1.10.0
- 1.10.1
- 1.10.2
- 1.11.0
- 1.12.0
- 1.13.0
- 1.13.1
- 1.14.0
- 1.14.1
- 1.15.0
- 1.16.0
- 1.16.1
- 1.16.2
- 1.17.0
- 1.2.1
- 1.2.2
- 1.2.3
- 1.3.0
- 1.4.0
- 1.4.1
- 1.5.0
- 1.6.0
- 1.7.0
- 1.8.0
- 1.8.1
- 1.9.0
- Affected ranges
- ECOSYSTEM: ≤ 1.17.0
No fix published
onnx Ubuntu:Pro:24.04:LTS
- Versions
- 1.13.1-3
- 1.13.1-3build1
- 1.14.1-2
- 1.14.1-2.1
- 1.14.1-2.1build1
- 1.14.1-2.1build2
- Affected ranges
- ECOSYSTEM: < 1.14.1-2.1ubuntu0.1~esm1
Update to 1.14.1-2.1ubuntu0.1~esm1