CVE-2024-52809
CVE-2024-52809 · Cross-site Scripting vulnerability with prototype pollution in vue-i18n
This page contains facts from public vulnerability sources. Check the original advisory before updating.
vue-i18n is an internationalization plugin for Vue.js. In affected versions vue-i18n can be passed locale messages to `createI18n` or `useI18n`. When locale message ASTs are generated in development mode there is a possibility of Cross-site Scripting attack. This issue has been addressed in versions 9.14.2, and 10.0.5. Users are advised to upgrade. There are no known workarounds for this vulnerability.
CVSS 5.3 · Medium · EPSS 0.7% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
vue-i18n
- Versions
- < 9.14.2: Affected
- >= 10.0.0, < 10.0.5: Affected
No fix published
@intlify/core-base npm
- Affected ranges
- SEMVER: ≥ 9.3.0, < 9.14.2
Update to 9.14.2
vue-i18n npm
- Affected ranges
- SEMVER: ≥ 9.3.0, < 9.14.2
Update to 9.14.2
@intlify/core npm
- Affected ranges
- SEMVER: ≥ 9.3.0, < 9.14.2
Update to 9.14.2
@intlify/vue-i18n-core npm
- Affected ranges
- SEMVER: ≥ 9.3.0, < 9.14.2
Update to 9.14.2
petite-vue-i18n npm
- Affected ranges
- SEMVER: ≥ 10.0.0, < 10.0.5
Update to 10.0.5
@intlify/core-base npm
- Affected ranges
- SEMVER: ≥ 10.0.0, < 10.0.5
Update to 10.0.5
vue-i18n npm
- Affected ranges
- SEMVER: ≥ 10.0.0, < 10.0.5
Update to 10.0.5
@intlify/core npm
- Affected ranges
- SEMVER: ≥ 10.0.0, < 10.0.5
Update to 10.0.5
@intlify/vue-i18n-core npm
- Affected ranges
- SEMVER: ≥ 10.0.0, < 10.0.5
Update to 10.0.5