p PatchFirst

CVE-2024-52867

CVE-2024-52867

This page contains facts from public vulnerability sources. Check the original advisory before updating.

guix-daemon in GNU Guix before 5ab3c4c allows privilege escalation because build outputs are accessible by local users before file metadata concerns (e.g., for setuid and setgid programs) are properly addressed. The vulnerability can be remediated within the product via certain pull, reconfigure, and restart actions. Both 5ab3c4c and 5582241 are needed to resolve the vulnerability.

CVSS 8.1 · High · EPSS 0.2% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • guix Debian:11

    Versions
    • 1.2.0-4
    • 1.2.0-4+deb11u1
    • 1.2.0-4+deb11u2
    Affected ranges
    • ECOSYSTEM: < 1.2.0-4+deb11u3

    Update to 1.2.0-4+deb11u3

  • guix Ubuntu:Pro:22.04:LTS

    Versions
    • 1.2.0-4
    • 1.3.0-2
    • 1.3.0-4
    Affected ranges
    • ECOSYSTEM: < 1.3.0-4ubuntu0.1~esm1

    Update to 1.3.0-4ubuntu0.1~esm1

  • guix Ubuntu:Pro:24.04:LTS

    Versions
    • 1.4.0-5
    • 1.4.0-6
    • 1.4.0-6build1
    Affected ranges
    • ECOSYSTEM: < 1.4.0-6ubuntu0.1~esm1

    Update to 1.4.0-6ubuntu0.1~esm1

Original sources

Check your server →