CVE-2024-5312
CVE-2024-5312 · Cross-Site Scripting vulnerability in PHP Server Monitor
This page contains facts from public vulnerability sources. Check the original advisory before updating.
PHP Server Monitor, version 3.2.0, is vulnerable to an XSS via the /phpservermon-3.2.0/vendor/phpmailer/phpmailer/test_script/index.php page in all visible parameters. An attacker could create a specially crafted URL, send it to a victim and retrieve their session details.
CVSS 6.3 · Medium · EPSS 0.3% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
php server monitor
- Versions
- 3,2,0: Affected
No fix published
phpservermon/phpservermon Packagist
- Versions
- v3.1.0
- v3.1.1
- v3.2.0
- v3.2.0-rc1
- v3.2.1
- v3.2.2
- Affected ranges
- ECOSYSTEM: < 3.3.0
Update to 3.3.0