p PatchFirst

CVE-2024-53457

CVE-2024-53457

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A stored cross-site scripting (XSS) vulnerability in the Device Settings section of LibreNMS v24.9.0 to v24.10.0 allows attackers to execute arbitrary web scripts or HTML via a crafted payload injected into the Display Name parameter.

CVSS 5.4 · Medium · EPSS 46.4% · Fix available

Published
Updated

Stack: php

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • librenms/librenms Packagist

    Versions
    • 24.10.0
    • 24.10.1
    • 24.9.0
    • 24.9.1
    Affected ranges
    • ECOSYSTEM: ≥ 24.9.0, < 24.11.0

    Update to 24.11.0

Original sources

Check your server →