p PatchFirst

CVE-2024-53526

CVE-2024-53526

This page contains facts from public vulnerability sources. Check the original advisory before updating.

composio >=0.5.40 is vulnerable to Command Execution in composio_openai, composio_claude, and composio_julep via the handle_tool_calls function.

CVSS 6.4 · Medium · EPSS 0.6% · Fix available

Published
Updated

Stack: python

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • composio-claude PyPI

    Versions
    • 0.5.40
    • 0.5.41
    • 0.5.42
    • 0.5.43
    • 0.5.44
    • 0.5.45
    • 0.5.46
    • 0.5.47
    • 0.5.48rc1
    • 0.5.49
    • 0.5.50
    • 0.5.51
    • 0.5.51rc1
    • 0.5.52rc1
    • 0.5.52rc2
    • 0.6.0
    • 0.6.0rc1
    • 0.6.1
    • 0.6.2
    • 0.6.3
    • 0.6.4
    • 0.6.5
    • 0.6.6
    • 0.6.7
    • 0.6.8
    Affected ranges
    • ECOSYSTEM: ≥ 0.5.40, < 0.6.9

    Update to 0.6.9

  • composio-openai PyPI

    Versions
    • 0.5.40
    • 0.5.41
    • 0.5.42
    • 0.5.43
    • 0.5.44
    • 0.5.45
    • 0.5.46
    • 0.5.47
    • 0.5.48rc1
    • 0.5.49
    • 0.5.50
    • 0.5.51
    • 0.5.51rc1
    • 0.5.52rc1
    • 0.5.52rc2
    • 0.6.0
    • 0.6.0rc1
    • 0.6.1
    • 0.6.2
    • 0.6.3
    • 0.6.4
    • 0.6.5
    • 0.6.6
    • 0.6.7
    • 0.6.8
    Affected ranges
    • ECOSYSTEM: ≥ 0.5.40, < 0.6.9

    Update to 0.6.9

  • composio-julep PyPI

    Versions
    • 0.5.40
    • 0.5.41
    • 0.5.42
    • 0.5.43
    • 0.5.44
    • 0.5.45
    • 0.5.46
    • 0.5.47
    • 0.5.48rc1
    • 0.5.49
    • 0.5.50
    • 0.5.51
    • 0.5.51rc1
    • 0.5.52rc1
    • 0.5.52rc2
    • 0.6.0
    • 0.6.0rc1
    • 0.6.1
    • 0.6.2
    • 0.6.3
    • 0.6.4
    • 0.6.5
    • 0.6.6
    • 0.6.7
    • 0.6.8
    Affected ranges
    • ECOSYSTEM: ≥ 0.5.40, < 0.6.9

    Update to 0.6.9

Original sources

Check your server →