CVE-2024-53900
CVE-2024-53900
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Mongoose before 8.8.3 can improperly use $where in match, leading to search injection.
CVSS 9.1 · Critical · EPSS 4.0% · Public exploit · Fix available
- Published
- Updated
Stack: node
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
mongoose npm
- Affected ranges
- SEMVER: ≥ 8.0.0-rc0, < 8.8.3
Update to 8.8.3
mongoose npm
- Affected ranges
- SEMVER: ≥ 7.0.0-rc0, < 7.8.3
Update to 7.8.3
mongoose npm
- Affected ranges
- SEMVER: ≥ 6.0.0-rc0, < 6.13.5
Update to 6.13.5
mongoose npm
- Affected ranges
- SEMVER: ≥ 3.6.0-rc0, < 5.13.23
Update to 5.13.23
Original sources
- https://www.npmjs.com/package/mongoose?activeTab=versions
- https://github.com/Automattic/mongoose/releases
- https://github.com/Automattic/mongoose/blob/master/CHANGELOG.md
- https://github.com/Automattic/mongoose/commit/c9e86bff7eef477da75a29af62a06d41a835a156
- https://github.com/advisories/GHSA-m7xq-9374-9rvx
- https://nvd.nist.gov/vuln/detail/CVE-2024-53900