p PatchFirst

CVE-2024-5435

CVE-2024-5435 · Generation of Error Message Containing Sensitive Information in GitLab

This page contains facts from public vulnerability sources. Check the original advisory before updating.

An issue has been discovered discovered in GitLab EE/CE affecting all versions starting from 15.10 before 17.1.7, all versions starting from 17.2 before 17.2.5, all versions starting from 17.3 before 17.3.2 will disclose user password from repository mirror configuration.

CVSS 4.5 · Medium · EPSS 0.5% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • gitlab

    Versions
    • ≥ 15.10, < 17.1.7: Affected (semver)
    • ≥ 17.2, < 17.2.5: Affected (semver)
    • ≥ 17.3, < 17.3.2: Affected (semver)

    Update to 17.1.7; Update to 17.2.5; Update to 17.3.2

  • gitlab Ubuntu:16.04:LTS

    Versions
    • 8.4.3+dfsg-9
    • 8.4.3+dfsg-12
    • 8.5.8+dfsg-5
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →