p PatchFirst

CVE-2024-5443

CVE-2024-5443 · Remote Code Execution via Path Traversal in parisneo/lollms

This page contains facts from public vulnerability sources. Check the original advisory before updating.

CVE-2024-4320 describes a vulnerability in the parisneo/lollms software, specifically within the `ExtensionBuilder().build_extension()` function. The vulnerability arises from the `/mount_extension` endpoint, where a path traversal issue allows attackers to navigate beyond the intended directory structure. This is facilitated by the `data.category` and `data.folder` parameters accepting empty strings (`""`), which, due to inadequate input sanitization, can lead to the construction of a `package_path` that points to the root directory. Consequently, if an attacker can create a `config.yaml` file in a controllable path, this path can be appended to the `extensions` list and trigger the execution of `__init__.py` in the current directory, leading to remote code execution. The vulnerability affects versions up to 5.9.0, and has been addressed in version 9.8.

CVSS 9.8 · Critical · EPSS 1.2% · Fix available

Published
Updated

Stack: python

Affected products and versions

  • parisneo/lollms

    Versions
    • ≥ unspecified, < 9.8: Affected (custom)

    Update to 9.8

  • lollms PyPI

    Versions
    • 5.9.0
    • 5.9.1
    • 5.9.2
    • 5.9.3
    • 5.9.4
    • 5.9.5
    • 6.0.0
    • 6.0.1
    • 6.0.2
    • 6.0.3
    • 6.0.5
    • 6.0.6
    • 6.0.7
    • 6.0.8
    • 6.0.9
    • 6.1.1
    • 6.2.0
    • 6.4.0
    • 6.5.0
    • 6.5.1
    • 6.5.2
    • 6.6.0
    • 6.7.0
    • 6.9.0
    • 7.2.0
    • 9.3.0
    • 9.5.0
    Affected ranges
    • ECOSYSTEM: ≥ 5.9.0, < 9.5.1

    Update to 9.5.1

Original sources

Check your server →