CVE-2024-5569
CVE-2024-5569 · Denial of Service via crafted zip file in jaraco/zipp
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A Denial of Service (DoS) vulnerability exists in the jaraco/zipp library, affecting all versions prior to 3.19.1. The vulnerability is triggered when processing a specially crafted zip file that leads to an infinite loop. This issue also impacts the zipfile module of CPython, as features from the third-party zipp library are later merged into CPython, and the affected code is identical in both projects. The infinite loop can be initiated through the use of functions affecting the `Path` module in both zipp and zipfile, such as `joinpath`, the overloaded division operator, and `iterdir`. Although the infinite loop is not resource exhaustive, it prevents the application from responding. The vulnerability was addressed in version 3.19.1 of jaraco/zipp.
CVSS 6.2 · Medium · EPSS 0.2% · Fix available
- Published
- Updated
Affected products and versions
jaraco/zipp
- Versions
- ≥ unspecified, < 3.19.1: Affected (custom)
Update to 3.19.1
python-zipp Debian:12
- Versions
- 1.0.0-6
- Affected ranges
- ECOSYSTEM: < 1.0.0-6+deb12u1
Update to 1.0.0-6+deb12u1
python-zipp Debian:13
- Affected ranges
- ECOSYSTEM: < 3.19.2-1
Update to 3.19.2-1
zipp PyPI
- Versions
- 0.1.0
- 0.2.0
- 0.2.1
- 0.3.0
- 0.3.1
- 0.3.2
- 0.3.3
- 0.4.0
- 0.5.0
- 0.5.1
- 0.5.2
- 0.6.0
- 1.0.0
- 1.1.0
- 1.1.1
- 1.2.0
- 2.0.0
- 2.0.1
- 2.1.0
- 2.2.0
- 2.2.1
- 3.0.0
- 3.1.0
- 3.10.0
- 3.11.0
- 3.12.0
- 3.12.1
- 3.13.0
- 3.14.0
- 3.15.0
- 3.16.0
- 3.16.1
- 3.16.2
- 3.17.0
- 3.18.0
- 3.18.1
- 3.18.2
- 3.19.0
- 3.2.0
- 3.3.0
- 3.3.1
- 3.3.2
- 3.4.0
- 3.4.1
- 3.4.2
- 3.5.0
- 3.5.1
- 3.6.0
- 3.7.0
- 3.8.0
- 3.8.1
- 3.9.0
- 3.9.1
- Affected ranges
- ECOSYSTEM: < 3.19.1
Update to 3.19.1
python-zipp Ubuntu:20.04:LTS
- Versions
- 0.5.2-2
- 0.6.0-1
- 1.0.0-1
- Affected ranges
- ECOSYSTEM: < 1.0.0-1ubuntu0.1
Update to 1.0.0-1ubuntu0.1
python-zipp Ubuntu:22.04:LTS
- Versions
- 1.0.0-3
- Affected ranges
- ECOSYSTEM: < 1.0.0-3ubuntu0.1
Update to 1.0.0-3ubuntu0.1
python-zipp Ubuntu:24.04:LTS
- Versions
- 1.0.0-6
- Affected ranges
- ECOSYSTEM: < 1.0.0-6ubuntu0.1
Update to 1.0.0-6ubuntu0.1