CVE-2024-56144
CVE-2024-56144 · Stored XSS-LibreNMS-Display Name 2 in librenms
This page contains facts from public vulnerability sources. Check the original advisory before updating.
librenms is a community-based GPL-licensed network monitoring system. Affected versions are subject to a stored XSS on the parameters (Replace $DEVICE_ID with your specific $DEVICE_ID value):`/device/$DEVICE_ID/edit` -> param: display. Librenms versions up to 24.11.0 allow remote attackers to inject malicious scripts. When a user views or interacts with the page displaying the data, the malicious script executes immediately, leading to potential unauthorized actions or data exposure. This issue has been addressed in release version 24.12.0. Users are advised to upgrade. There are no known workarounds for this vulnerability.
CVSS 4.6 · Medium · EPSS 0.4% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
librenms
- Versions
- < 24.12.0: Affected
No fix published
librenms/librenms Packagist
- Versions
- 24.11.10
- Affected ranges
- ECOSYSTEM: ≥ 24.11.10, < 24.12.0
Update to 24.12.0