p PatchFirst

CVE-2024-5655

CVE-2024-5655 · Improper Access Control in GitLab

This page contains facts from public vulnerability sources. Check the original advisory before updating.

An issue was discovered in GitLab CE/EE affecting all versions starting from 15.8 prior to 16.11.5, starting from 17.0 prior to 17.0.3, and starting from 17.1 prior to 17.1.1, which allows an attacker to trigger a pipeline as another user under certain circumstances.

CVSS 9.6 · Critical · EPSS 7.5% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • gitlab

    Versions
    • ≥ 15.8, < 16.11.5: Affected (semver)
    • ≥ 17.0, < 17.0.3: Affected (semver)
    • ≥ 17.1, < 17.1.1: Affected (semver)

    Update to 16.11.5; Update to 17.0.3; Update to 17.1.1

  • gitlab Ubuntu:16.04:LTS

    Versions
    • 8.4.3+dfsg-9
    • 8.4.3+dfsg-12
    • 8.5.8+dfsg-5
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →