CVE-2024-6162
CVE-2024-6162 · Undertow: url-encoded request path information can be broken on ajp-listener
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A vulnerability was found in Undertow, where URL-encoded request paths can be mishandled during concurrent requests on the AJP listener. This issue arises because the same buffer is used to decode the paths for multiple requests simultaneously, leading to incorrect path information being processed. As a result, the server may attempt to access the wrong path, causing errors such as "404 Not Found" or other application failures. This flaw can potentially lead to a denial of service, as legitimate resources become inaccessible due to the path mix-up.
CVSS 7.5 · High · EPSS 1.7% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
eap 8.0.1
No fix published
red hat build of apache camel 4.4.1 for spring boot 3.2
No fix published
red hat jboss enterprise application platform expansion pack
No fix published
red hat build of apache camel for spring boot 3
No fix published
red hat build of apache camel - hawtio 4
No fix published
red hat build of keycloak
No fix published
red hat data grid 8
No fix published
red hat fuse 7
No fix published
red hat integration camel k 1
No fix published
red hat jboss data grid 7
No fix published
red hat jboss enterprise application platform 7
No fix published
red hat jboss enterprise application platform 8
No fix published
red hat jboss enterprise application platform expansion pack
No fix published
red hat process automation 7
No fix published
red hat single sign-on 7
No fix published
undertow Debian:14
- Versions
- 1.3.11-1
- 1.3.16-1
- 1.3.19-1
- 1.3.21-1
- 1.3.23-1
- 1.3.4-1
- 1.3.5-1
- 1.3.7-1
- 1.4.0-1
- 1.4.1-1
- 1.4.18-1
- 1.4.20-1
- 1.4.21-1
- 1.4.21-2
- 1.4.22-1
- 1.4.23-1
- 1.4.23-2
- 1.4.23-3
- 1.4.25-1
- 1.4.25-2
- 1.4.3-1
- 1.4.4-1
- 1.4.6-1
- 1.4.7-1
- 1.4.8-1
- 2.0.23-1
- 2.0.25-1
- 2.0.26-1
- 2.0.27-1
- 2.0.28-1
- 2.0.29-1
- 2.0.30-1
- 2.1.0-1
- 2.1.1-1
- 2.1.3-1
- 2.2.0-1
- 2.2.10-1
- 2.2.12-1
- 2.2.13-1
- 2.2.14-1
- 2.2.16-1
- 2.2.17-1
- 2.2.18-1
- 2.2.19-1
- 2.2.2-1
- 2.2.20-1
- 2.2.21-1
- 2.2.3-1
- 2.2.4-1
- 2.2.5-1
- 2.2.8-1
- 2.3.8-1
- 2.3.8-2
- Affected ranges
- ECOSYSTEM: < 2.3.18-1
Update to 2.3.18-1
undertow Ubuntu:Pro:16.04:LTS
- Versions
- 1.3.4-1
- 1.3.5-1
- 1.3.7-1
- 1.3.11-1
- 1.3.16-1
- 1.3.16-1ubuntu0.1~esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
undertow Ubuntu:Pro:18.04:LTS
- Versions
- 1.4.20-1
- 1.4.21-1
- 1.4.22-1
- 1.4.23-1
- 1.4.23-2build1
- 1.4.23-3
- 1.4.23-3ubuntu0.1~esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
undertow Ubuntu:Pro:20.04:LTS
- Versions
- 2.0.23-1
- 2.0.27-1
- 2.0.28-1
- 2.0.29-1
- 2.0.29-1ubuntu0.1~esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
undertow Ubuntu:Pro:22.04:LTS
- Versions
- 2.2.8-1
- 2.2.12-1
- 2.2.13-1
- 2.2.14-1
- 2.2.16-1
- 2.2.16-1ubuntu0.1~esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
undertow Ubuntu:Pro:24.04:LTS
- Versions
- 2.3.8-2
- 2.3.8-2ubuntu0.1~esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
undertow Ubuntu:25.10
- Versions
- 2.3.18-1
- 2.3.18-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
undertow Ubuntu:26.10
- Versions
- 2.3.20-1ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
undertow Ubuntu:26.04:LTS
- Versions
- 2.3.18-2
- 2.3.20-1
- 2.3.20-1ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://access.redhat.com/errata/RHSA-2024:1194
- https://access.redhat.com/errata/RHSA-2024:4386
- https://access.redhat.com/errata/RHSA-2024:4884
- https://access.redhat.com/security/cve/CVE-2024-6162
- https://bugzilla.redhat.com/show_bug.cgi?id=2293069
- https://issues.redhat.com/browse/JBEAP-26268
- https://security.netapp.com/advisory/ntap-20241129-0009/
- https://nvd.nist.gov/vuln/detail/CVE-2024-6162