p PatchFirst

CVE-2024-6239

CVE-2024-6239 · Poppler: pdfinfo: crash in broken documents when using -dests parameter

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A flaw was found in the Poppler's Pdfinfo utility. This issue occurs when using -dests parameter with pdfinfo utility. By using certain malformed input files, an attacker could cause the utility to crash, leading to a denial of service.

CVSS 7.5 · High · EPSS 0.8% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • red hat enterprise linux 8

    Versions
    • ≥ 0:20.11.0-12.el8_10: Not affected (rpm)

    No fix published

  • red hat enterprise linux 9

    Versions
    • ≥ 0:21.01.0-21.el9: Not affected (rpm)

    No fix published

  • red hat enterprise linux 10

    No fix published

  • red hat enterprise linux 6

    No fix published

  • red hat enterprise linux 7

    No fix published

  • red hat enterprise linux 8

    No fix published

  • red hat enterprise linux 9

    No fix published

  • poppler Debian:12

    Versions
    • 22.12.0-2
    • 22.12.0-2+deb12u1
    • 22.12.0-2+deb12u2
    Affected ranges
    • ECOSYSTEM: < 22.12.0-2+deb12u3

    Update to 22.12.0-2+deb12u3

  • poppler Debian:13

    Affected ranges
    • ECOSYSTEM: < 24.08.0-2

    Update to 24.08.0-2

  • poppler Debian:14

    Affected ranges
    • ECOSYSTEM: < 24.08.0-2

    Update to 24.08.0-2

  • poppler Ubuntu:Pro:16.04:LTS

    Versions
    • 0.33.0-0ubuntu3
    • 0.37.0-0ubuntu1
    • 0.38.0-0ubuntu1
    • 0.41.0-0ubuntu1
    • 0.41.0-0ubuntu1.1
    • 0.41.0-0ubuntu1.2
    • 0.41.0-0ubuntu1.3
    • 0.41.0-0ubuntu1.4
    • 0.41.0-0ubuntu1.5
    • 0.41.0-0ubuntu1.6
    • 0.41.0-0ubuntu1.7
    • 0.41.0-0ubuntu1.8
    • 0.41.0-0ubuntu1.9
    • 0.41.0-0ubuntu1.10
    • 0.41.0-0ubuntu1.11
    • 0.41.0-0ubuntu1.12
    • 0.41.0-0ubuntu1.13
    • 0.41.0-0ubuntu1.14
    • 0.41.0-0ubuntu1.15
    • 0.41.0-0ubuntu1.16
    • 0.41.0-0ubuntu1.16+esm1
    • 0.41.0-0ubuntu1.16+esm2
    • 0.41.0-0ubuntu1.16+esm3
    • 0.41.0-0ubuntu1.16+esm4
    • 0.41.0-0ubuntu1.16+esm5
    • 0.41.0-0ubuntu1.16+esm6
    • 0.41.0-0ubuntu1.16+esm7
    • 0.41.0-0ubuntu1.16+esm8
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • poppler Ubuntu:Pro:18.04:LTS

    Versions
    • 0.57.0-2ubuntu4
    • 0.57.0-2ubuntu5
    • 0.62.0-1ubuntu1
    • 0.62.0-2ubuntu1
    • 0.62.0-2ubuntu2
    • 0.62.0-2ubuntu2.1
    • 0.62.0-2ubuntu2.2
    • 0.62.0-2ubuntu2.4
    • 0.62.0-2ubuntu2.5
    • 0.62.0-2ubuntu2.6
    • 0.62.0-2ubuntu2.7
    • 0.62.0-2ubuntu2.8
    • 0.62.0-2ubuntu2.9
    • 0.62.0-2ubuntu2.10
    • 0.62.0-2ubuntu2.11
    • 0.62.0-2ubuntu2.12
    • 0.62.0-2ubuntu2.13
    • 0.62.0-2ubuntu2.14
    • 0.62.0-2ubuntu2.14+esm1
    • 0.62.0-2ubuntu2.14+esm2
    • 0.62.0-2ubuntu2.14+esm3
    • 0.62.0-2ubuntu2.14+esm4
    • 0.62.0-2ubuntu2.14+esm5
    • 0.62.0-2ubuntu2.14+esm6
    • 0.62.0-2ubuntu2.14+esm7
    • 0.62.0-2ubuntu2.14+esm8
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • poppler Ubuntu:Pro:20.04:LTS

    Versions
    • 0.80.0-0ubuntu1
    • 0.80.0-0ubuntu3
    • 0.80.0-0ubuntu4
    • 0.80.0-0ubuntu5
    • 0.85.0-1ubuntu1
    • 0.85.0-1ubuntu3
    • 0.86.1-0ubuntu1
    • 0.86.1-0ubuntu1.1
    • 0.86.1-0ubuntu1.2
    • 0.86.1-0ubuntu1.3
    • 0.86.1-0ubuntu1.4
    • 0.86.1-0ubuntu1.5
    • 0.86.1-0ubuntu1.6
    • 0.86.1-0ubuntu1.7
    • 0.86.1-0ubuntu1.7+esm1
    • 0.86.1-0ubuntu1.7+esm2
    • 0.86.1-0ubuntu1.7+esm3
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • poppler Ubuntu:22.04:LTS

    Versions
    • 21.06.1-1
    • 21.11.0-1~ubuntu2
    • 22.02.0-2
    • 22.02.0-2ubuntu0.1
    • 22.02.0-2ubuntu0.2
    • 22.02.0-2ubuntu0.3
    • 22.02.0-2ubuntu0.4
    Affected ranges
    • ECOSYSTEM: < 22.02.0-2ubuntu0.5

    Update to 22.02.0-2ubuntu0.5

  • poppler Ubuntu:24.04:LTS

    Versions
    • 23.08.0-2ubuntu1
    • 23.12.0-1ubuntu2
    • 24.02.0-1ubuntu2
    • 24.02.0-1ubuntu8
    • 24.02.0-1ubuntu9
    Affected ranges
    • ECOSYSTEM: < 24.02.0-1ubuntu9.1

    Update to 24.02.0-1ubuntu9.1

Original sources

Check your server →