p PatchFirst

CVE-2024-6307

CVE-2024-6307 · WordPress Core < 6.5.5 - Authenticated (Contributor+) Stored Cross-Site Scripting via HTML API

This page contains facts from public vulnerability sources. Check the original advisory before updating.

WordPress Core is vulnerable to Stored Cross-Site Scripting via the HTML API in various versions prior to 6.5.5 due to insufficient input sanitization and output escaping on URLs. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

CVSS 6.4 · Medium · EPSS 0.5% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • wordpress

    Versions
    • ≥ 5.9, ≤ 5.9.9: Affected (semver)
    • ≥ 6.0, ≤ 6.0.8: Affected (semver)
    • ≥ 6.1, ≤ 6.1.6: Affected (semver)
    • ≥ 6.2, ≤ 6.2.5: Affected (semver)
    • ≥ 6.3, ≤ 6.3.4: Affected (semver)
    • ≥ 6.4, ≤ 6.4.4: Affected (semver)
    • ≥ 6.5, ≤ 6.5.4: Affected (semver)

    No fix published

  • wordpress Debian:12

    Versions
    • 6.1.1+dfsg1-1
    • 6.1.6+dfsg1-0+deb12u1
    Affected ranges
    • ECOSYSTEM: < 6.1.9+dfsg1-0+deb12u1

    Update to 6.1.9+dfsg1-0+deb12u1

  • wordpress Debian:13

    Affected ranges
    • ECOSYSTEM: < 6.5.5+dfsg1-1

    Update to 6.5.5+dfsg1-1

  • wordpress Debian:14

    Affected ranges
    • ECOSYSTEM: < 6.5.5+dfsg1-1

    Update to 6.5.5+dfsg1-1

  • wordpress Ubuntu:16.04:LTS

    Versions
    • 4.3+dfsg-1
    • 4.3.1+dfsg-1
    • 4.4+dfsg-1
    • 4.4.1+dfsg-1
    • 4.4.2+dfsg-1
    • 4.4.2+dfsg-1ubuntu1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • wordpress Ubuntu:18.04:LTS

    Versions
    • 4.8.2+dfsg-2
    • 4.8.3+dfsg-1
    • 4.9.1+dfsg-1
    • 4.9.2+dfsg-1
    • 4.9.4+dfsg-1
    • 4.9.5+dfsg1-1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • wordpress Ubuntu:20.04:LTS

    Versions
    • 5.2.2+dfsg1-1
    • 5.2.4+dfsg1-1
    • 5.3.2+dfsg1-1
    • 5.3.2+dfsg1-1ubuntu1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • wordpress Ubuntu:22.04:LTS

    Versions
    • 5.7.1+dfsg1-2ubuntu1
    • 5.8.1+dfsg1-2ubuntu1
    • 5.8.2+dfsg1-1ubuntu1
    • 5.8.3+dfsg1-1ubuntu1
    • 5.8.3+dfsg1-1ubuntu1.1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • wordpress Ubuntu:24.04:LTS

    Versions
    • 6.2+dfsg1-1ubuntu1
    • 6.4.3+dfsg1-1ubuntu1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →