CVE-2024-6485
CVE-2024-6485 · XSS in Bootstrap button component
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A security vulnerability has been discovered in bootstrap that could enable Cross-Site Scripting (XSS) attacks. The vulnerability is associated with the data-loading-text attribute within the button plugin. This vulnerability can be exploited by injecting malicious JavaScript code into the attribute, which would then be executed when the button's loading state is triggered.
CVSS 6.4 · Medium · EPSS 0.5% · Fix available
- Published
- Updated
Affected products and versions
bootstrap
- Versions
- ≥ 1.4.0, ≤ 3.4.1: Affected (semver)
No fix published
bootstrap-sass
- Versions
- ≥ 2.3.2, ≤ 3.4.3: Affected (semver)
No fix published
twitter-bootstrap3 Debian:12
- Versions
- 3.4.1+dfsg-3
- Affected ranges
- ECOSYSTEM: < 3.4.1+dfsg-3+deb12u1
Update to 3.4.1+dfsg-3+deb12u1
twitter-bootstrap3 Debian:13
- Affected ranges
- ECOSYSTEM: < 3.4.1+dfsg-4
Update to 3.4.1+dfsg-4
twitter-bootstrap3 Debian:14
- Affected ranges
- ECOSYSTEM: < 3.4.1+dfsg-4
Update to 3.4.1+dfsg-4
bootstrap npm
- Affected ranges
- SEMVER: ≥ 1.4.0, ≤ 3.4.1
No fix published
twitter-bootstrap3 Ubuntu:Pro:16.04:LTS
- Versions
- 3.3.5+dfsg-1
- 3.3.5+dfsg-2
- 3.3.6+dfsg-1
- Affected ranges
- ECOSYSTEM: < 3.3.6+dfsg-1ubuntu0.1~esm1
Update to 3.3.6+dfsg-1ubuntu0.1~esm1
twitter-bootstrap3 Ubuntu:Pro:18.04:LTS
- Versions
- 3.3.7+dfsg-2
- Affected ranges
- ECOSYSTEM: < 3.3.7+dfsg-2ubuntu0.1~esm1
Update to 3.3.7+dfsg-2ubuntu0.1~esm1
twitter-bootstrap3 Ubuntu:22.04:LTS
- Versions
- 3.4.1+dfsg-2
- Affected ranges
- ECOSYSTEM: < 3.4.1+dfsg-2+deb11u2build0.22.04.1
Update to 3.4.1+dfsg-2+deb11u2build0.22.04.1
twitter-bootstrap3 Ubuntu:24.04:LTS
- Versions
- 3.4.1+dfsg-3
- Affected ranges
- ECOSYSTEM: < 3.4.1+dfsg-3+deb12u1build0.24.04.1
Update to 3.4.1+dfsg-3+deb12u1build0.24.04.1