p PatchFirst

CVE-2024-6678

CVE-2024-6678 · Authentication Bypass by Spoofing in GitLab

This page contains facts from public vulnerability sources. Check the original advisory before updating.

An issue was discovered in GitLab CE/EE affecting all versions starting from 8.14 prior to 17.1.7, starting from 17.2 prior to 17.2.5, and starting from 17.3 prior to 17.3.2, which allows an attacker to trigger a pipeline as an arbitrary user under certain circumstances.

CVSS 9.9 · Critical · EPSS 2.0% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • gitlab

    Versions
    • ≥ 8.14, < 17.1.7: Affected (semver)
    • ≥ 17.2, < 17.2.5: Affected (semver)
    • ≥ 17.3, < 17.3.2: Affected (semver)

    Update to 17.1.7; Update to 17.2.5; Update to 17.3.2

  • gitlab Ubuntu:16.04:LTS

    Versions
    • 8.4.3+dfsg-9
    • 8.4.3+dfsg-12
    • 8.5.8+dfsg-5
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →