CVE-2024-6825
CVE-2024-6825 · Remote Code Execution in BerriAI/litellm
This page contains facts from public vulnerability sources. Check the original advisory before updating.
BerriAI/litellm version 1.40.12 contains a vulnerability that allows remote code execution. The issue exists in the handling of the 'post_call_rules' configuration, where a callback function can be added. The provided value is split at the final '.' mark, with the last part considered the function name and the remaining part appended with the '.py' extension and imported. This allows an attacker to set a system method, such as 'os.system', as a callback, enabling the execution of arbitrary commands when a chat response is processed.
CVSS 8.8 · High · EPSS 1.7% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
berriai/litellm
- Versions
- ≥ unspecified, < v1.65.4.dev6: Affected (custom)
Update to v1.65.4.dev6
litellm PyPI
- Affected ranges
- ECOSYSTEM: ≥ 1.40.3.dev2, ≤ 1.40.12
No fix published
litellm PyPI
- Versions
- 1.40.10
- 1.40.11
- 1.40.12
- 1.40.3
- 1.40.4
- 1.40.5
- 1.40.6
- 1.40.7
- 1.40.8
- 1.40.9
- Affected ranges
- ECOSYSTEM: ≥ 1.40.3.dev2, ≤ 1.40.12
No fix published