CVE-2024-7042
CVE-2024-7042 · Prompt Injection in langchain-ai/langchainjs Leading to SQL Injection
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A vulnerability in the GraphCypherQAChain class of langchain-ai/langchainjs versions 0.2.5 and all versions with this class allows for prompt injection, leading to SQL injection. This vulnerability permits unauthorized data manipulation, data exfiltration, denial of service (DoS) by deleting all data, breaches in multi-tenant security environments, and data integrity issues. Attackers can create, update, or delete nodes and relationships without proper authorization, extract sensitive data, disrupt services, access data across different tenants, and compromise the integrity of the database.
CVSS 4.9 · Medium · EPSS 0.3% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
langchain-ai/langchainjs
- Versions
- ≥ unspecified, < 0.3.1: Affected (custom)
Update to 0.3.1
@langchain/community npm
- Affected ranges
- SEMVER: < 0.3.3
Update to 0.3.3