CVE-2024-7055
CVE-2024-7055 · FFmpeg pnmdec.c pnm_decode_frame heap-based overflow
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A vulnerability was found in FFmpeg up to 7.0.1. It has been classified as critical. This affects the function pnm_decode_frame in the library /libavcodec/pnmdec.c. The manipulation leads to heap-based buffer overflow. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 7.0.2 is able to address this issue. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-273651.
CVSS 6.9 · Medium · EPSS 1.4% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
ffmpeg
- Versions
- 7.0.0: Affected
- 7.0.1: Affected
No fix published
ffmpeg Debian:12
- Versions
- 7:5.1.3-1
- 7:5.1.3-2
- 7:5.1.4-0+deb12u1
- 7:5.1.5-0+deb12u1
- Affected ranges
- ECOSYSTEM: < 7:5.1.6-0+deb12u1
Update to 7:5.1.6-0+deb12u1
ffmpeg Debian:13
- Affected ranges
- ECOSYSTEM: < 7:7.0.2-1
Update to 7:7.0.2-1
ffmpeg Debian:14
- Affected ranges
- ECOSYSTEM: < 7:7.0.2-1
Update to 7:7.0.2-1
libav Ubuntu:Pro:14.04:LTS
- Versions
- 6:0.8.7-1ubuntu2
- 6:9.10-1ubuntu1
- 6:9.10-1ubuntu2
- 6:9.10-1ubuntu5
- 6:9.10-1ubuntu6
- 6:9.10-1ubuntu7
- 6:9.11-2ubuntu1
- 6:9.11-2ubuntu2
- 6:9.13-0ubuntu0.14.04.1
- 6:9.14-0ubuntu0.14.04.1
- 6:9.16-0ubuntu0.14.04.1
- 6:9.18-0ubuntu0.14.04.1
- 6:9.20-0ubuntu0.14.04.1
- 6:9.20-0ubuntu0.14.04.1+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
ffmpeg Ubuntu:Pro:22.04:LTS
- Versions
- 7:4.4-6ubuntu5
- 7:4.4.1-2ubuntu1
- 7:4.4.1-3ubuntu1
- 7:4.4.1-3ubuntu2
- 7:4.4.1-3ubuntu3
- 7:4.4.1-3ubuntu5
- 7:4.4.2-0ubuntu0.22.04.1
- 7:4.4.2-0ubuntu0.22.04.1+esm1
- 7:4.4.2-0ubuntu0.22.04.1+esm2
- 7:4.4.2-0ubuntu0.22.04.1+esm3
- 7:4.4.2-0ubuntu0.22.04.1+esm4
- 7:4.4.2-0ubuntu0.22.04.1+esm5
- 7:4.4.2-0ubuntu0.22.04.1+esm6
- 7:4.4.2-0ubuntu0.22.04.1+esm7
- 7:4.4.2-0ubuntu0.22.04.1+esm8
- Affected ranges
- ECOSYSTEM: < 7:4.4.2-0ubuntu0.22.04.1+esm9
Update to 7:4.4.2-0ubuntu0.22.04.1+esm9
ffmpeg Ubuntu:Pro:24.04:LTS
- Versions
- 7:6.0-6ubuntu1
- 7:6.0-9ubuntu1
- 7:6.1-2ubuntu1
- 7:6.1-3ubuntu1
- 7:6.1-4ubuntu1
- 7:6.1-5ubuntu1
- 7:6.1.1-1ubuntu1
- 7:6.1.1-3ubuntu1
- 7:6.1.1-3ubuntu5
- 7:6.1.1-3ubuntu5+esm1
- 7:6.1.1-3ubuntu5+esm2
- 7:6.1.1-3ubuntu5+esm3
- 7:6.1.1-3ubuntu5+esm4
- Affected ranges
- ECOSYSTEM: < 7:6.1.1-3ubuntu5+esm5
Update to 7:6.1.1-3ubuntu5+esm5
Original sources
- https://vuldb.com/?id.273651
- https://vuldb.com/?ctiid.273651
- https://vuldb.com/?submit.376532
- https://github.com/CookedMelon/ReportCVE/tree/main/FFmpeg/poc3
- https://ffmpeg.org/download.html
- https://ffmpeg.org/
- https://lists.debian.org/debian-lts-announce/2024/10/msg00019.html
- https://nvd.nist.gov/vuln/detail/CVE-2024-7055