p PatchFirst

CVE-2024-7057

CVE-2024-7057 · Improper Access Control in GitLab

This page contains facts from public vulnerability sources. Check the original advisory before updating.

An information disclosure vulnerability in GitLab CE/EE affecting all versions starting from 16.7 prior to 17.0.5, starting from 17.1 prior to 17.1.3, and starting from 17.2 prior to 17.2.1 where job artifacts can be inappropriately exposed to users lacking the proper authorization level.

CVSS 4.3 · Medium · EPSS 0.4% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • gitlab

    Versions
    • ≥ 16.7, < 17.0.5: Affected (semver)
    • ≥ 17.1, < 17.1.3: Affected (semver)
    • ≥ 17.2, < 17.2.1: Affected (semver)

    Update to 17.0.5; Update to 17.1.3; Update to 17.2.1

  • gitlab Ubuntu:16.04:LTS

    Versions
    • 8.4.3+dfsg-9
    • 8.4.3+dfsg-12
    • 8.5.8+dfsg-5
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →