CVE-2024-7340
CVE-2024-7340 · W&B Weave server remote arbitrary file leak and privilege escalation
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The Weave server API allows remote users to fetch files from a specific directory, but due to a lack of input validation, it is possible to traverse and leak arbitrary files remotely. In various common scenarios, this allows a low-privileged user to assume the role of the server admin.
CVSS 8.8 · High · EPSS 5.0% · Public exploit · Fix available
- Published
- Updated
Stack: python
Affected products and versions
weave PyPI
- Versions
- 0.20.0
- 0.20.0.dev1
- 0.20.0.dev2
- 0.21.0
- 0.22.0
- 0.23.0
- 0.24.0
- 0.24.1
- 0.25.0
- 0.26.0
- 0.27.0
- 0.28.0
- 0.29.0
- 0.30.0
- 0.31.0
- 0.32.0
- 0.33.0
- 0.34.0
- 0.35.0
- 0.36.0
- 0.37.0
- 0.38.0
- 0.39.0
- 0.40.0
- 0.41.0
- 0.42.0
- 0.43.0
- 0.44.0
- 0.45.0
- 0.46.0
- 0.47.0
- 0.48.0
- 0.49.0
- 0.50.0
- 0.50.1
- 0.50.2
- 0.50.3
- 0.50.4
- 0.50.5
- 0.50.6
- 0.50.7
- Affected ranges
- ECOSYSTEM: < 0.50.8
Update to 0.50.8