CVE-2024-7553
CVE-2024-7553 · Accessing Untrusted Directory May Allow Local Privilege Escalation
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Incorrect validation of files loaded from a local untrusted directory may allow local privilege escalation if the underlying operating systems is Windows. This may result in the application executing arbitrary behaviour determined by the contents of untrusted files. This issue affects MongoDB Server v5.0 versions prior to 5.0.27, MongoDB Server v6.0 versions prior to 6.0.16, MongoDB Server v7.0 versions prior to 7.0.12, MongoDB Server v7.3 versions prior 7.3.3, MongoDB C Driver versions prior to 1.26.2 and MongoDB PHP Driver versions prior to 1.18.1. Required Configuration: Only environments with Windows as the underlying operating system is affected by this issue
CVSS 7.3 · High · EPSS 0.3% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
mongodb server
- Versions
- ≥ 5.0, < 5.0.27: Affected (custom)
- ≥ 6.0, < 6.0.16: Affected (custom)
- ≥ 7.0, < 7.0.12: Affected (custom)
- ≥ 7.3, < 7.3.3: Affected (custom)
Update to 5.0.27; Update to 6.0.16; Update to 7.0.12; Update to 7.3.3
mongodb c driver
- Versions
- ≥ 0, < 1.26.2: Affected (custom)
Update to 1.26.2
mongodb php driver
- Versions
- ≥ 0, < 1.18.1: Affected (custom)
Update to 1.18.1
mongodb Ubuntu:Pro:14.04:LTS
- Versions
- 1:2.4.6-0ubuntu5
- 1:2.4.6-0ubuntu6
- 1:2.4.8-1ubuntu1
- 1:2.4.8-2
- 1:2.4.9-1
- 1:2.4.9-1ubuntu1
- 1:2.4.9-1ubuntu2
- 1:2.4.9-1ubuntu2+esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
mongodb Ubuntu:Pro:16.04:LTS
- Versions
- 1:2.6.10-0ubuntu1
- 1:2.6.10-0ubuntu1+esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
php-mongodb Ubuntu:16.04:LTS
- Versions
- 1.1.2-2~ubuntu1
- 1.1.5-1~build1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
mongodb Ubuntu:Pro:18.04:LTS
- Versions
- 1:3.4.7-1
- 1:3.4.7-1ubuntu1
- 1:3.4.7-1ubuntu2
- 1:3.4.7-1ubuntu4
- 1:3.4.14-3ubuntu1
- 1:3.4.14-3ubuntu2
- 1:3.6.3-0ubuntu1
- 1:3.6.3-0ubuntu1.1
- 1:3.6.3-0ubuntu1.3
- 1:3.6.3-0ubuntu1.4
- 1:3.6.3-0ubuntu1.4+esm1
- 1:3.6.3-0ubuntu1.4+esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
php-mongodb Ubuntu:18.04:LTS
- Versions
- 1.2.3-1build1
- 1.3.4-1build1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
mongo-c-driver Ubuntu:Pro:20.04:LTS
- Versions
- 1.15.0-1
- 1.15.1-1
- 1.15.2-1
- 1.16.0-1
- 1.16.1-1
- 1.16.1-1build1
- 1.16.1-1build2
- 1.16.1-1ubuntu0.1~esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
mongodb Ubuntu:Pro:20.04:LTS
- Versions
- 1:3.6.9+really3.6.8+90~g8e540c0b6d-0ubuntu2
- 1:3.6.9+really3.6.8+90~g8e540c0b6d-0ubuntu5
- 1:3.6.9+really3.6.8+90~g8e540c0b6d-0ubuntu5.2
- 1:3.6.9+really3.6.8+90~g8e540c0b6d-0ubuntu5.3
- 1:3.6.9+really3.6.8+90~g8e540c0b6d-0ubuntu5.3+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
php-mongodb Ubuntu:20.04:LTS
- Versions
- 1.5.5-1build1
- 1.6.1-4
- 1.6.1-4build1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
mongo-c-driver Ubuntu:22.04:LTS
- Versions
- 1.18.0-1
- 1.19.1-1
- 1.19.2-1
- 1.20.0-1
- 1.20.0-1build1
- 1.20.1-1
- 1.21.0-1
- 1.21.0-1build1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
php-mongodb Ubuntu:22.04:LTS
- Versions
- 1.9.0+1.7.5-2build2
- 1.11.1+1.9.2+1.7.5-4
- 1.12.0+1.9.2+1.7.5-3
- 1.12.0+1.9.2+1.7.5-4
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
mongo-c-driver Ubuntu:24.04:LTS
- Versions
- 1.24.3-1
- 1.24.4-1
- 1.25.1-1
- 1.25.2-1
- 1.25.4-1
- 1.26.0-1
- 1.26.0-1.1ubuntu1
- 1.26.0-1.1ubuntu2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
php-mongodb Ubuntu:24.04:LTS
- Versions
- 1.15.0+1.11.1+1.9.2+1.7.5-1build1
- 1.15.0+1.11.1+1.9.2+1.7.5-1ubuntu1
- 1.15.0+1.11.1+1.9.2+1.7.5-1ubuntu2
- 1.15.0+1.11.1+1.9.2+1.7.5-1ubuntu3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published