CVE-2024-7954
CVE-2024-7954 · SPIP porte_plume Plugin Arbitrary PHP Execution
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The porte_plume plugin used by SPIP before 4.30-alpha2, 4.2.13, and 4.1.16 is vulnerable to an arbitrary code execution vulnerability. A remote and unauthenticated attacker can execute arbitrary PHP as the SPIP user by sending a crafted HTTP request.
CVSS 9.8 · Critical · EPSS 90.1% · Public exploit · Fix available
- Published
- Updated
Stack: system
Affected products and versions
spip
- Versions
- ≥ 4.3.0-alpha, < 4.3.0-alpha2: Affected (custom)
- ≥ 4.2.0, < 4.2.13: Affected (semver)
- ≥ 4.1.0, < 4.1.16: Affected (semver)
Update to 4.1.16; Update to 4.2.13; Update to 4.3.0-alpha2
spip Debian:13
- Affected ranges
- ECOSYSTEM: < 4.3.0+dfsg-1
Update to 4.3.0+dfsg-1
spip Debian:14
- Affected ranges
- ECOSYSTEM: < 4.3.0+dfsg-1
Update to 4.3.0+dfsg-1
spip Ubuntu:Pro:16.04:LTS
- Versions
- 3.0.20-1
- 3.0.21-1
- 3.0.21-1ubuntu1
- 3.0.21-1ubuntu1+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
spip Ubuntu:Pro:18.04:LTS
- Versions
- 3.1.4-3
- 3.1.4-4~deb9u3build0.18.04.1
- 3.1.4-4~deb9u5build0.18.04.1
- 3.1.4-4~deb9u5ubuntu0.1~esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
spip Ubuntu:Pro:20.04:LTS
- Versions
- 3.2.4-1
- 3.2.5-1
- 3.2.7-1
- 3.2.7-1ubuntu0.1
- 3.2.7-1ubuntu0.1+esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
spip Ubuntu:22.04:LTS
- Versions
- 3.2.11-3
- 3.2.12-1
- 4.0.2-1
- 4.0.4-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
spip Ubuntu:24.04:LTS
- Versions
- 4.1.11+dfsg-1
- 4.1.12+dfsg-1
- 4.1.13+dfsg-1
- 4.1.15+dfsg-1
- 4.2.9+dfsg-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published