p PatchFirst

CVE-2024-8661

CVE-2024-8661 · Concrete CMS version 9.0.0 to 9.3.3 and below 8.5.19 are vulnerable to Stored XSS in the "Next&Previous Nav" block

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Concrete CMS versions 9.0.0 to 9.3.3 and below 8.5.19 are vulnerable to Stored XSS in the "Next&Previous Nav" block. A rogue administrator could add a malicious payload by executing it in the browsers of targeted users. The Concrete CMS Security Team gave this vulnerability a CVSS v4 score of 4.6 with vector CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:A/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N https://www.first.org/cvss/calculator/4.0#CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:A/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N  Since the "Next&Previous Nav" block output was not sufficiently sanitized, the malicious payload could be executed in the browsers of targeted users. Thanks, Chu Quoc Khanh for reporting.

CVSS 4.6 · Medium · EPSS 0.4% · Fix available

Published
Updated

Stack: php

Affected products and versions

  • concrete cms

    Versions
    • ≥ 9.0.0, < 9.3.4: Affected (git)
    • ≥ 5.0.0, < 8.5.19: Affected (git)

    Update to 8.5.19; Update to 9.3.4

  • concrete5/concrete5 Packagist

    Versions
    • 8.0
    • 8.0.1
    • 8.0.2
    • 8.0.3
    • 8.1.0
    • 8.2.0
    • 8.2.0RC2
    • 8.2.1
    • 8.3.0
    • 8.3.1
    • 8.3.2
    • 8.4.0
    • 8.4.0RC3
    • 8.4.0RC4
    • 8.4.1
    • 8.4.2
    • 8.4.3
    • 8.4.4
    • 8.4.5
    • 8.5.0
    • 8.5.0RC1
    • 8.5.0RC2
    • 8.5.1
    • 8.5.10
    • 8.5.11
    • 8.5.12
    • 8.5.13
    • 8.5.14
    • 8.5.15
    • 8.5.16
    • 8.5.17
    • 8.5.18
    • 8.5.2
    • 8.5.3
    • 8.5.4
    • 8.5.5
    • 8.5.6
    • 8.5.6RC1
    • 8.5.7
    • 8.5.8
    • 8.5.9
    Affected ranges
    • ECOSYSTEM: < 8.5.19

    Update to 8.5.19

  • concrete5/concrete5 Packagist

    Versions
    • 9.0.0
    • 9.0.1
    • 9.0.2
    • 9.1.0
    • 9.1.1
    • 9.1.2
    • 9.1.3
    • 9.2.0
    • 9.2.0RC2
    • 9.2.1
    • 9.2.2
    • 9.2.3
    • 9.2.4
    • 9.2.5
    • 9.2.6
    • 9.2.7
    • 9.2.8
    • 9.2.9
    • 9.3.0
    • 9.3.1
    • 9.3.2
    • 9.3.3
    Affected ranges
    • ECOSYSTEM: ≥ 9.0.0, < 9.3.4

    Update to 9.3.4

Original sources

Check your server →