p PatchFirst

CVE-2024-8970

CVE-2024-8970 · Incorrect Authorization in GitLab

This page contains facts from public vulnerability sources. Check the original advisory before updating.

An issue was discovered in GitLab CE/EE affecting all versions starting from 11.6 prior to 17.2.9, starting from 17.3 prior to 17.3.5, and starting from 17.4 prior to 17.4.2, which allows an attacker to trigger a pipeline as another user under certain circumstances.

CVSS 8.2 · High · EPSS 0.7% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • gitlab

    Versions
    • ≥ 11.6, < 17.2.9: Affected (semver)
    • ≥ 17.3, < 17.3.5: Affected (semver)
    • ≥ 17.4, < 17.4.2: Affected (semver)

    Update to 17.2.9; Update to 17.3.5; Update to 17.4.2

  • gitlab Ubuntu:16.04:LTS

    Versions
    • 8.4.3+dfsg-9
    • 8.4.3+dfsg-12
    • 8.5.8+dfsg-5
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →