p PatchFirst

CVE-2024-9164

CVE-2024-9164 · Missing Authentication for Critical Function in GitLab

This page contains facts from public vulnerability sources. Check the original advisory before updating.

An issue was discovered in GitLab EE affecting all versions starting from 12.5 prior to 17.2.9, starting from 17.3, prior to 17.3.5, and starting from 17.4 prior to 17.4.2, which allows running pipelines on arbitrary branches.

CVSS 9.6 · Critical · EPSS 1.0% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • gitlab

    Versions
    • ≥ 12.5, < 17.2.9: Affected (semver)
    • ≥ 17.3, < 17.3.5: Affected (semver)
    • ≥ 17.4, < 17.4.2: Affected (semver)

    Update to 17.2.9; Update to 17.3.5; Update to 17.4.2

  • gitlab Ubuntu:16.04:LTS

    Versions
    • 8.4.3+dfsg-9
    • 8.4.3+dfsg-12
    • 8.5.8+dfsg-5
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →