CVE-2024-9427
CVE-2024-9427 · Koji: escape html tag characters in the query string
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A vulnerability in Koji was found. An unsanitized input allows for an XSS attack. Javascript code from a malicious link could be reflected in the resulting web page. It is not expected to be able to submit an action or make a change in Koji due to existing XSS protections in the code
CVSS 5.4 · Medium · EPSS 0.3% · Fix available
- Published
- Updated
Affected products and versions
koji PyPI
- Versions
- 1.35.0
- Affected ranges
- ECOSYSTEM: ≥ 1.35.0, < 1.35.1
Update to 1.35.1
koji PyPI
- Versions
- 1.34.0
- 1.34.1
- 1.34.2
- Affected ranges
- ECOSYSTEM: ≥ 1.34.0, < 1.34.3
Update to 1.34.3
koji PyPI
- Versions
- 1.15.0
- 1.16.0
- 1.16.1
- 1.17.0
- 1.18.0
- 1.19.0
- 1.19.1
- 1.20.0
- 1.20.1
- 1.21.0
- 1.21.1
- 1.22.0
- 1.22.1
- 1.23.0
- 1.23.1
- 1.24.0
- 1.24.1
- 1.25.0
- 1.25.1
- 1.26.0
- 1.26.1
- 1.27.0
- 1.27.1
- 1.28.0
- 1.28.1
- 1.29.0
- 1.29.1
- 1.30.0
- 1.30.1
- 1.31.0
- 1.31.1
- 1.32.0
- 1.32.1
- 1.33.0
- 1.33.1
- Affected ranges
- ECOSYSTEM: < 1.33.2
Update to 1.33.2
koji PyPI
- Versions
- 1.15.0
- 1.16.0
- 1.16.1
- 1.17.0
- 1.18.0
- 1.19.0
- 1.19.1
- 1.20.0
- 1.20.1
- 1.21.0
- 1.21.1
- 1.22.0
- 1.22.1
- 1.23.0
- 1.23.1
- 1.24.0
- 1.24.1
- 1.25.0
- 1.25.1
- 1.26.0
- 1.26.1
- 1.27.0
- 1.27.1
- 1.28.0
- 1.28.1
- 1.29.0
- 1.29.1
- 1.30.0
- 1.30.1
- 1.31.0
- 1.31.1
- 1.32.0
- 1.32.1
- 1.33.0
- 1.33.1
- 1.34.0
- 1.34.1
- 1.34.2
- 1.35.0
- Affected ranges
- ECOSYSTEM: < 1.33.2 ∪ ≥ 1.34.0, < 1.34.3 ∪ ≥ 1.35.0, < 1.35.1
Update to 1.33.2; Update to 1.34.3; Update to 1.35.1
koji Ubuntu:16.04:LTS
- Versions
- 1.10.0-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
koji Ubuntu:18.04:LTS
- Versions
- 1.10.0-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published