CVE-2024-9774
CVE-2024-9774 · Python-sql: python-sql unary operators does not escape non-expression
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A vulnerability was found in python-sql where unary operators do not escape non-Expression.
CVSS 6.5 · Medium · EPSS 0.7% · Fix available
- Published
- Updated
Affected products and versions
python-sql Debian:12
- Versions
- 1.4.0-1
- Affected ranges
- ECOSYSTEM: < 1.4.0-1+deb12u1
Update to 1.4.0-1+deb12u1
python-sql Debian:13
- Affected ranges
- ECOSYSTEM: < 1.5.2-1
Update to 1.5.2-1
python-sql Debian:14
- Affected ranges
- ECOSYSTEM: < 1.5.2-1
Update to 1.5.2-1
python-sql PyPI
- Versions
- 0.1
- 0.2
- 0.3
- 0.4
- 0.5
- 0.6
- 0.7
- 0.8
- 0.9
- 1.0.0
- 1.1.0
- 1.2.0
- 1.2.1
- 1.2.2
- 1.3.0
- 1.4.0
- 1.4.1
- 1.4.2
- 1.4.3
- 1.5.0
- 1.5.1
- Affected ranges
- ECOSYSTEM: < 1.5.2
Update to 1.5.2
python-sql Ubuntu:Pro:16.04:LTS
- Versions
- 0.7-1
- 0.8-1
- Affected ranges
- ECOSYSTEM: < 0.8-1ubuntu0.1~esm1
Update to 0.8-1ubuntu0.1~esm1
python-sql Ubuntu:Pro:18.04:LTS
- Versions
- 0.9-1
- Affected ranges
- ECOSYSTEM: < 0.9-1ubuntu0.1~esm1
Update to 0.9-1ubuntu0.1~esm1
python-sql Ubuntu:Pro:20.04:LTS
- Versions
- 1.0.0-1
- 1.0.0-2
- 1.1.0-1
- Affected ranges
- ECOSYSTEM: < 1.1.0-1ubuntu0.1~esm1
Update to 1.1.0-1ubuntu0.1~esm1
python-sql Ubuntu:Pro:22.04:LTS
- Versions
- 1.2.1-1
- 1.3.0-1
- Affected ranges
- ECOSYSTEM: < 1.3.0-1ubuntu0.1~esm1
Update to 1.3.0-1ubuntu0.1~esm1
python-sql Ubuntu:24.04:LTS
- Versions
- 1.4.0-1
- Affected ranges
- ECOSYSTEM: < 1.4.0-1+deb12u1build0.24.04.1
Update to 1.4.0-1+deb12u1build0.24.04.1