p PatchFirst

CVE-2024-9870

CVE-2024-9870 · Unintended Proxy or Intermediary ('Confused Deputy') in GitLab

This page contains facts from public vulnerability sources. Check the original advisory before updating.

An external service interaction vulnerability in GitLab EE affecting all versions from 15.11 prior to 17.6.5, 17.7 prior to 17.7.4, and 17.8 prior to 17.8.2 allows an attacker to send requests from the GitLab server to unintended services.

CVSS 4.3 · Medium · EPSS 0.4% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • gitlab

    Versions
    • ≥ 15.11, < 17.6.5: Affected (semver)
    • ≥ 17.7, < 17.7.4: Affected (semver)
    • ≥ 17.8, < 17.8.2: Affected (semver)

    Update to 17.6.5; Update to 17.7.4; Update to 17.8.2

  • gitlab Ubuntu:16.04:LTS

    Versions
    • 8.4.3+dfsg-9
    • 8.4.3+dfsg-12
    • 8.5.8+dfsg-5
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →