p PatchFirst

CVE-2025-0194

CVE-2025-0194 · Insertion of Sensitive Information into Externally-Accessible File or Directory in GitLab

This page contains facts from public vulnerability sources. Check the original advisory before updating.

An issue was discovered in GitLab CE/EE affecting all versions starting from 17.4 prior to 17.5.5, starting from 17.6 prior to 17.6.3, and starting from 17.7 prior to 17.7.1. Under certain conditions, access tokens may have been logged when API requests were made in a specific manner.

CVSS 6.5 · Medium · EPSS 0.5% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • gitlab

    Versions
    • ≥ 17.4, < 17.5.5: Affected (semver)
    • ≥ 17.6, < 17.6.3: Affected (semver)
    • ≥ 17.7, < 17.7.1: Affected (semver)

    Update to 17.5.5; Update to 17.6.3; Update to 17.7.1

  • gitlab Ubuntu:16.04:LTS

    Versions
    • 8.4.3+dfsg-9
    • 8.4.3+dfsg-12
    • 8.5.8+dfsg-5
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →